summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/slop')
-rw-r--r--dev-ruby/slop/ChangeLog8
-rw-r--r--dev-ruby/slop/slop-3.3.2.ebuild24
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-ruby/slop/ChangeLog b/dev-ruby/slop/ChangeLog
index 493d79d6e59a..921ee756843f 100644
--- a/dev-ruby/slop/ChangeLog
+++ b/dev-ruby/slop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/slop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/ChangeLog,v 1.12 2012/06/09 07:03:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/ChangeLog,v 1.13 2012/07/05 22:39:03 flameeyes Exp $
+
+*slop-3.3.2 (05 Jul 2012)
+
+ 05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +slop-3.3.2.ebuild:
+ Version bump.
*slop-3.3.1 (09 Jun 2012)
@@ -56,4 +61,3 @@
16 Jul 2011; Hans de Graaff <graaff@gentoo.org> +slop-2.0.0.ebuild,
+metadata.xml:
Initial import. Dependency of forthcoming dev-ruby/pry.
-
diff --git a/dev-ruby/slop/slop-3.3.2.ebuild b/dev-ruby/slop/slop-3.3.2.ebuild
new file mode 100644
index 000000000000..4bc58db31d42
--- /dev/null
+++ b/dev-ruby/slop/slop-3.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/slop/slop-3.3.2.ebuild,v 1.1 2012/07/05 22:39:03 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API."
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/slop/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="injekt-slop-*"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"