summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec/rspec-2.5.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-2.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-2.5.0.ebuild b/dev-ruby/rspec/rspec-2.5.0.ebuild
new file mode 100644
index 000000000000..18587d52b9ff
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.5.0.ebuild,v 1.1 2011/02/19 09:28:49 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-2.5*
+ ~dev-ruby/rspec-expectations-${PV}
+ ~dev-ruby/rspec-mocks-${PV}"