summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx/sphinx-0.4.2.ebuild')
-rw-r--r--dev-python/sphinx/sphinx-0.4.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/sphinx/sphinx-0.4.2.ebuild b/dev-python/sphinx/sphinx-0.4.2.ebuild
index cdc5e445dc5b..3f8148a07fc8 100644
--- a/dev-python/sphinx/sphinx-0.4.2.ebuild
+++ b/dev-python/sphinx/sphinx-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.4.2.ebuild,v 1.1 2008/08/01 06:51:29 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.4.2.ebuild,v 1.2 2008/08/01 16:47:52 pythonhead Exp $
inherit distutils
@@ -12,16 +12,16 @@ HOMEPAGE="http://sphinx.pocoo.org/"
SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~sparc ~x86"
IUSE="doc test"
-DEPEND="!sparc? ( !ppc? ( !ia64? ( test? ( dev-python/nose ) ) ) )
- >=dev-python/pygments-0.8
+RDEPEND=">=dev-python/pygments-0.8
>=dev-python/jinja-1.1
>=dev-python/docutils-0.4
dev-python/setuptools"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
S="${WORKDIR}/${MY_P}"
@@ -43,6 +43,8 @@ src_install() {
}
src_test() {
+ #Tests fail without this directory, fixed in next release
+ #http://bugs.python.org/issue3484
mkdir tests/root/_build
- PYTHONPATH=. ${python} tests/run.py || die "Tests failed"
+ PYTHONPATH=. "${python}" tests/run.py || die "Tests failed"
}