summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis-py/redis-py-2.4.12.ebuild')
-rw-r--r--dev-python/redis-py/redis-py-2.4.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/redis-py/redis-py-2.4.12.ebuild b/dev-python/redis-py/redis-py-2.4.12.ebuild
new file mode 100644
index 000000000000..b148c4200e8b
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.4.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/redis-py/redis-py-2.4.12.ebuild,v 1.1 2012/05/08 08:59:41 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+# Tests are not distributed in the tarball.
+# DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="http://github.com/andymccurdy/redis-py http://pypi.python.org/pypi/redis"
+SRC_URI="mirror://github/andymccurdy/${PN}/redis-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/redis-${PV}"
+
+DOCS="README.md CHANGES"
+PYTHON_MODNAME="redis"