summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jinja/jinja-2.5.2.ebuild')
-rw-r--r--dev-python/jinja/jinja-2.5.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/jinja/jinja-2.5.2.ebuild b/dev-python/jinja/jinja-2.5.2.ebuild
index f3d9056931ab..c27cfb3c83d8 100644
--- a/dev-python/jinja/jinja-2.5.2.ebuild
+++ b/dev-python/jinja/jinja-2.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.5.2.ebuild,v 1.1 2010/08/18 09:49:47 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jinja/jinja-2.5.2.ebuild,v 1.2 2010/09/10 21:41:24 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -28,15 +28,21 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+DISTUTILS_GLOBAL_OPTIONS=("--with-debugsupport")
DOCS="CHANGES"
PYTHON_MODNAME="jinja2"
+src_prepare() {
+ distutils_src_prepare
+ find examples -name "*.py[co]" -print0 | xargs -0 rm -f
+}
+
src_compile(){
distutils_src_compile
if use doc; then
- cd docs
einfo "Generation of documentation"
+ cd docs
PYTHONPATH=".." emake html || die "Building of documentation failed"
fi
}