summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php4/phpdbg/phpdbg-2.11.32.ebuild')
-rw-r--r--dev-php4/phpdbg/phpdbg-2.11.32.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-php4/phpdbg/phpdbg-2.11.32.ebuild b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
index 10a428d8d819..358ca765cd6b 100644
--- a/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
+++ b/dev-php4/phpdbg/phpdbg-2.11.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/phpdbg-2.11.32.ebuild,v 1.4 2005/11/25 15:49:56 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/phpdbg/phpdbg-2.11.32.ebuild,v 1.5 2006/04/15 22:26:55 chtekk Exp $
PHP_EXT_NAME="dbg"
PHP_EXT_INI="yes"
@@ -10,18 +10,17 @@ inherit php-ext-source-r1
KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}${PL}-src.tar.gz"
HOMEPAGE="http://dd.cron.ru/dbg/"
LICENSE="dbgphp"
SLOT="0"
IUSE=""
-MY_P="dbg-${PV}${PL}"
-SRC_URI="mirror://sourceforge/dbg2/${MY_P}-src.tar.gz"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/dbg-${PV}${PL}"
need_php_by_category
-src_compile() {
+pkg_setup() {
has_php
# phpdbg does not work with Zend Thread Safety (ZTS)
@@ -32,6 +31,10 @@ src_compile() {
eerror "USE flag off when you compile dev-lang/php."
die "phpdbg does not support ZTS"
fi
+}
+
+src_compile() {
+ has_php
my_conf="--enable-dbg=shared --with-dbg-profiler"
php-ext-source-r1_src_compile
@@ -50,5 +53,6 @@ pkg_postinst() {
}
pkg_postrm() {
- einfo "Please reload Apache to activate the changes."
+ einfo "You need to remove all lines referring to the debugger, and"
+ einfo "extension=dbg.so. Please reload Apache to activate the changes."
}