summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild')
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
index 7a0aba8b5d59..984bdedc486e 100644
--- a/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
+++ b/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild,v 1.1 2012/12/28 19:46:45 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.720.0.ebuild,v 1.2 2013/06/07 12:24:49 zlogene Exp $
EAPI=5
MODULE_AUTHOR=NLNETLABS
MODULE_VERSION=0.72
-inherit perl-module
+inherit toolchain-funcs perl-module
DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
@@ -40,3 +40,9 @@ src_prepare() {
# as it connects to 2001:7b8:206:1:0:1234:be21:e31e
myconf="${myconf} --no-online-tests --no-IPv6-tests"
}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+
+ perl-module_src_compile
+}