summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/lzo/lzo-2.01.ebuild')
-rw-r--r--dev-libs/lzo/lzo-2.01.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/lzo/lzo-2.01.ebuild b/dev-libs/lzo/lzo-2.01.ebuild
new file mode 100644
index 000000000000..e7dff5643b8b
--- /dev/null
+++ b/dev-libs/lzo/lzo-2.01.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lzo/lzo-2.01.ebuild,v 1.1 2005/07/16 23:58:29 dragonheart Exp $
+
+DESCRIPTION="An extremely fast compression and decompression library"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="x86? ( dev-lang/nasm )"
+RDEPEND=""
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS doc/LZO*
+ docinto examples
+ dodoc examples/*.c examples/Makefile
+}