summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libIDL/libIDL-0.7.4-r2.ebuild')
-rw-r--r--dev-libs/libIDL/libIDL-0.7.4-r2.ebuild32
1 files changed, 9 insertions, 23 deletions
diff --git a/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild b/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild
index 3e717e3429d7..34dd957fbd44 100644
--- a/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild
+++ b/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/libIDL-0.7.4-r2.ebuild,v 1.3 2002/08/01 18:02:36 seemant Exp $
# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
DEBUG="yes"
@@ -14,37 +14,23 @@ S=${WORKDIR}/${P}
DESCRIPTION="CORBA tree builder"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
HOMEPAGE="http://www.gnome.org"
+
SLOT="0"
LICENSE="LGPL-2.1"
+KEYWORDS="x86"
RDEPEND=">=dev-libs/glib-2.0.0
- >=sys-devel/flex-2.5.4"
-DEPEND="${RDEPEND} >=dev-util/pkgconfig-0.12.0"
-
-src_compile() {
- local myconf
+ >=sys-devel/flex-2.5.4"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --enable-debug=yes || die
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+src_compile() {
+ econf --enable-debug=yes || die
emake || die
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
+ einstall || die
dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README*
}
-
-
-
-
-