summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/go-fuse/go-fuse-9999.ebuild')
-rw-r--r--dev-libs/go-fuse/go-fuse-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/go-fuse/go-fuse-9999.ebuild b/dev-libs/go-fuse/go-fuse-9999.ebuild
new file mode 100644
index 000000000000..a3937b5e34b0
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/go-fuse/go-fuse-9999.ebuild,v 1.1 2013/10/21 00:58:01 zerochaos Exp $
+
+EAPI=5
+
+inherit git-r3 multilib
+
+RESTRICT="strip"
+
+DESCRIPTION="native bindings for the FUSE kernel module"
+HOMEPAGE="https://github.com/hanwen/go-fuse"
+EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/go"
+RDEPEND=""
+
+GO_PN="github.com/hanwen/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+
+export GOPATH="${S}"
+
+src_compile() {
+#no examples right now
+# example/hello example/loopback example/zipfs \
+# example/multizip example/unionfs example/memfs \
+# example/autounionfs ; \
+#or tests
+#fuse/test
+for d in fuse fuse/pathfs zipfs unionfs
+do
+ go build -v -x -work ${GO_PN}/${d} || die
+done
+}
+
+src_install() {
+for d in fuse fuse/pathfs zipfs unionfs
+do
+ go install -v -x -work ${GO_PN}/${d} || die
+done
+
+#insinto /usr/$(get_libdir)
+#insinto /usr/lib/go/src/pkg/${GO_PN}/
+#doins -r "${S}/pkg/linux_${ARCH}/${GO_PN}/."
+insinto /usr/lib/go/
+doins -r "${S}/."
+}