summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.6.8-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.6.8-r1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.6.8-r1.ebuild b/dev-lang/python/python-2.6.8-r1.ebuild
index 54f109996e9f..951bb2ca9f0c 100644
--- a/dev-lang/python/python-2.6.8-r1.ebuild
+++ b/dev-lang/python/python-2.6.8-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 2 requires Python 2.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="0"
@@ -49,6 +52,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"
@@ -72,6 +76,8 @@ pkg_setup() {
ewarn "You might need to migrate your databases."
fi
fi
+
+ python-any-r1_pkg_setup
}
src_prepare() {
@@ -183,7 +189,7 @@ src_configure() {
}
src_compile() {
- emake EPYTHON="python${PV%%.*}" || die "emake failed"
+ default
# Work around bug 329499. See also bug 413751.
pax-mark m python