summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.6.1-r10.ebuild')
-rw-r--r--dev-lang/perl/perl-5.6.1-r10.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-lang/perl/perl-5.6.1-r10.ebuild b/dev-lang/perl/perl-5.6.1-r10.ebuild
index 45d160f10e63..fb49b5356546 100644
--- a/dev-lang/perl/perl-5.6.1-r10.ebuild
+++ b/dev-lang/perl/perl-5.6.1-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.6.1-r10.ebuild,v 1.8 2003/08/22 13:01:06 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.6.1-r10.ebuild,v 1.9 2003/09/06 22:27:51 msterret Exp $
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${P}.tar.gz"
@@ -30,7 +30,7 @@ src_compile() {
if [ "${ARCH}" = "alpha" ]; then
CFLAGS="${CFLAGS} -fPIC"
CXXFLAGS="${CXXFLAGS} -fPIC"
- fi
+ fi
local myconf
if [ "`use gdbm`" ]
@@ -94,7 +94,7 @@ src_compile() {
rm -rf ${S}
unpack ${A}
cd ${S}
-
+
# configure for libperl.a
# this is gross -- from Christian Gafton, Red Hat
cat > config.over <<EOF
@@ -148,7 +148,7 @@ EOF
mv Makefile Makefile_orig
sed -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
Makefile_orig > Makefile
-
+
#for some reason, this rm -f doesn't seem to actually do anything. So we explicitly use "Makefile"
#(rather than the default "makefile") in all make commands below.
#rm -f makefile x2p/makefile
@@ -166,20 +166,20 @@ EOF
echo "Skipping tests on this platform"
else
egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
- make -f Makefile test
+ make -f Makefile test
fi
}
src_install() {
-#The following is to handle international users. Perl does nls post-install
- export LC_ALL=C
+#The following is to handle international users. Perl does nls post-install
+ export LC_ALL=C
export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
insinto /usr/lib/perl5/${PV}/${PARCH}/CORE/
doins ${WORKDIR}/libperl.so
dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
-
+
# make -f Makefile \
# INSTALLMAN1DIR=${D}/usr/share/man/man1 \
@@ -212,7 +212,7 @@ src_install() {
dodoc Changes* Artistic Copying README Todo* AUTHORS
prepalldocs
-
+
# HTML Documentation
dodir /usr/share/doc/${PF}/html
${D}/usr/bin/perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html