summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gdl/files')
-rw-r--r--dev-lang/gdl/files/0.9.2-numpy.patch11
-rw-r--r--dev-lang/gdl/files/0.9.2-tests.patch142
-rw-r--r--dev-lang/gdl/files/0.9.3-netcdf-cxx.patch34
-rw-r--r--dev-lang/gdl/files/0.9.3-sstream.patch42
4 files changed, 0 insertions, 229 deletions
diff --git a/dev-lang/gdl/files/0.9.2-numpy.patch b/dev-lang/gdl/files/0.9.2-numpy.patch
deleted file mode 100644
index 3d0a88e2852b..000000000000
--- a/dev-lang/gdl/files/0.9.2-numpy.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gdl-0.9.2.orig/CMakeLists.txt 2011-12-22 20:18:17.000000000 +0000
-+++ gdl-0.9.2/CMakeLists.txt 2011-12-24 05:39:10.000000000 +0000
-@@ -476,7 +484,7 @@
- "${PYTHONMSG} ${PYTHON_MODULEMSG}")
- endif(NOT PYTHON_NUMPY_FOUND)
- set(LIBRARIES ${LIBRARIES} ${PYTHON_LIBRARIES})
-- include_directories(${PYTHON_INCLUDE_DIRS})
-+ include_directories(${PYTHON_INCLUDE_DIRS} ${PYTHON_NUMPY_INCLUDE_DIR})
- else(PYTHONLIBS_FOUND)
- message(FATAL_ERROR "Python is required but was not found.\n"
- "Use -DPYTHONDIR=DIR to specify the Python directory tree.\n"
diff --git a/dev-lang/gdl/files/0.9.2-tests.patch b/dev-lang/gdl/files/0.9.2-tests.patch
deleted file mode 100644
index 464ac8e1f7d9..000000000000
--- a/dev-lang/gdl/files/0.9.2-tests.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-diff -Nur gdl-0.9.2.orig/testsuite/CMakeLists.txt gdl-0.9.2/testsuite/CMakeLists.txt
---- gdl-0.9.2.orig/testsuite/CMakeLists.txt 2011-12-22 20:18:17.000000000 +0000
-+++ gdl-0.9.2/testsuite/CMakeLists.txt 2011-12-25 00:40:51.000000000 +0000
-@@ -13,6 +13,7 @@
- *(p-4)=0;
- setenv(\"LC_COLLATE\",\"C\",1);
- setenv(\"GDL_PATH\",\"+${BASE_SOURCE}/testsuite/:+${BASE_SOURCE}/src/pro/\",1);
-+setenv(\"LD_LIBRARY_PATH\",\"+${BASE_BINARY}/testsuite\",1);
- execl(\"${BASE_BINARY}/src/gdl\",\"-quiet\",\"-e\",v[1],(char*)0);
- }
- ")
-@@ -21,10 +22,123 @@
- add_library(test_ce SHARED EXCLUDE_FROM_ALL libtest_ce.cpp)
- add_custom_target(check COMMAND ${CMAKE_BUILD_TOOL} test DEPENDS launchtest test_ce)
- get_target_property(LAUNCHTESTLOCATION launchtest LOCATION)
--execute_process(
-- COMMAND "fgrep" ".pro" "${BASE_SOURCE}/testsuite/Makefile.am"
-- COMMAND "awk" "{printf(\"%s;\",$1)}"
-- OUTPUT_VARIABLE TESTS)
--foreach(TEST ${TESTS})
-- add_test(${TEST} ${LAUNCHTESTLOCATION} ${TEST})
--endforeach(TEST TESTS)
-+
-+add_test(test_angles.pro ${LAUNCHTESTLOCATION} test_angles.pro)
-+add_test(test_base64.pro ${LAUNCHTESTLOCATION} test_base64.pro)
-+add_test(test_binfmt.pro ${LAUNCHTESTLOCATION} test_binfmt.pro)
-+add_test(test_bug_1779553.pro ${LAUNCHTESTLOCATION} test_bug_1779553.pro)
-+add_test(test_bug_2555865.pro ${LAUNCHTESTLOCATION} test_bug_2555865.pro)
-+add_test(test_bug_2610174.pro ${LAUNCHTESTLOCATION} test_bug_2610174.pro)
-+add_test(test_bug_2846561.pro ${LAUNCHTESTLOCATION} test_bug_2846561.pro)
-+add_test(test_bug_2876150.pro ${LAUNCHTESTLOCATION} test_bug_2876150.pro)
-+add_test(test_bug_2876161.pro ${LAUNCHTESTLOCATION} test_bug_2876161.pro)
-+# these two need display
-+if(X11)
-+ add_test(test_bug_2974380.pro ${LAUNCHTESTLOCATION} test_bug_2974380.pro)
-+ add_test(test_bug_3275334.pro ${LAUNCHTESTLOCATION} test_bug_3275334.pro)
-+ add_test(test_get_screen_size.pro ${LAUNCHTESTLOCATION} test_get_screen_size.pro)
-+endif(X11)
-+add_test(test_bug_3033108.pro ${LAUNCHTESTLOCATION} test_bug_3033108.pro)
-+add_test(test_bug_3054361.pro ${LAUNCHTESTLOCATION} test_bug_3054361.pro)
-+iF(NETCDF)
-+ add_test(test_bug_3055720.pro ${LAUNCHTESTLOCATION} test_bug_3055720.pro)
-+ add_test(test_bug_3057511.pro ${LAUNCHTESTLOCATION} test_bug_3057511.pro)
-+ add_test(test_bug_3057520.pro ${LAUNCHTESTLOCATION} test_bug_3057520.pro)
-+ add_test(test_bug_3061072.pro ${LAUNCHTESTLOCATION} test_bug_3061072.pro)
-+ add_test(test_bug_3100945.pro ${LAUNCHTESTLOCATION} test_bug_3100945.pro)
-+endif(NETCDF)
-+add_test(test_bug_3081887.pro ${LAUNCHTESTLOCATION} test_bug_3081887.pro)
-+add_test(test_bug_3085858.pro ${LAUNCHTESTLOCATION} test_bug_3085858.pro)
-+add_test(test_bug_3086851.pro ${LAUNCHTESTLOCATION} test_bug_3086851.pro)
-+add_test(test_bug_3091599.pro ${LAUNCHTESTLOCATION} test_bug_3091599.pro)
-+add_test(test_bug_3091610.pro ${LAUNCHTESTLOCATION} test_bug_3091610.pro)
-+add_test(test_bug_3104209.pro ${LAUNCHTESTLOCATION} test_bug_3104209.pro)
-+add_test(test_bug_3104214.pro ${LAUNCHTESTLOCATION} test_bug_3104214.pro)
-+add_test(test_bug_3104326.pro ${LAUNCHTESTLOCATION} test_bug_3104326.pro)
-+add_test(test_bug_3104349.pro ${LAUNCHTESTLOCATION} test_bug_3104349.pro)
-+add_test(test_bug_3147181.pro ${LAUNCHTESTLOCATION} test_bug_3147181.pro)
-+add_test(test_bug_3147733.pro ${LAUNCHTESTLOCATION} test_bug_3147733.pro)
-+add_test(test_bug_3151760.pro ${LAUNCHTESTLOCATION} test_bug_3151760.pro)
-+add_test(test_bug_3152899.pro ${LAUNCHTESTLOCATION} test_bug_3152899.pro)
-+add_test(test_bug_3189072.pro ${LAUNCHTESTLOCATION} test_bug_3189072.pro)
-+add_test(test_bug_3199465.pro ${LAUNCHTESTLOCATION} test_bug_3199465.pro)
-+add_test(test_bug_3244840.pro ${LAUNCHTESTLOCATION} test_bug_3244840.pro)
-+add_test(test_bug_3286031.pro ${LAUNCHTESTLOCATION} test_bug_3286031.pro)
-+add_test(test_bug_3288652.pro ${LAUNCHTESTLOCATION} test_bug_3288652.pro)
-+add_test(test_bug_3290532.pro ${LAUNCHTESTLOCATION} test_bug_3290532.pro)
-+add_test(test_bug_3296360.pro ${LAUNCHTESTLOCATION} test_bug_3296360.pro)
-+add_test(test_bug_3298378.pro ${LAUNCHTESTLOCATION} test_bug_3298378.pro)
-+add_test(test_bug_3300626.pro ${LAUNCHTESTLOCATION} test_bug_3300626.pro)
-+add_test(test_bug_3313522.pro ${LAUNCHTESTLOCATION} test_bug_3313522.pro)
-+if(MAGICK)
-+ add_test(test_bug_3376577.pro ${LAUNCHTESTLOCATION} test_bug_3376577.pro)
-+endif(MAGICK)
-+add_test(test_ce.pro ${LAUNCHTESTLOCATION} test_ce.pro)
-+add_test(test_clip.pro ${LAUNCHTESTLOCATION} test_clip.pro)
-+add_test(test_common.pro ${LAUNCHTESTLOCATION} test_common.pro)
-+if(UDUNITS)
-+ add_test(test_constants.pro ${LAUNCHTESTLOCATION} test_constants.pro)
-+endif(UDUNITS)
-+add_test(test_correlate.pro ${LAUNCHTESTLOCATION} test_correlate.pro)
-+add_test(test_deriv.pro ${LAUNCHTESTLOCATION} test_deriv.pro)
-+add_test(test_device.pro ${LAUNCHTESTLOCATION} test_device.pro)
-+add_test(test_dicom.pro ${LAUNCHTESTLOCATION} test_dicom.pro)
-+add_test(test_erfinv.pro ${LAUNCHTESTLOCATION} test_erfinv.pro)
-+add_test(test_execute.pro ${LAUNCHTESTLOCATION} test_execute.pro)
-+add_test(test_fft.pro ${LAUNCHTESTLOCATION} test_fft.pro)
-+add_test(test_file_basename.pro ${LAUNCHTESTLOCATION} test_file_basename.pro)
-+add_test(test_file_copy.pro ${LAUNCHTESTLOCATION} test_file_copy.pro)
-+add_test(test_file_delete.pro ${LAUNCHTESTLOCATION} test_file_delete.pro)
-+add_test(test_file_dirname.pro ${LAUNCHTESTLOCATION} test_file_dirname.pro)
-+add_test(test_file_search.pro ${LAUNCHTESTLOCATION} test_file_search.pro)
-+add_test(test_file_which.pro ${LAUNCHTESTLOCATION} test_file_which.pro)
-+add_test(test_fix.pro ${LAUNCHTESTLOCATION} test_fix.pro)
-+add_test(test_fixprint.pro ${LAUNCHTESTLOCATION} test_fixprint.pro)
-+add_test(test_gc.pro ${LAUNCHTESTLOCATION} test_gc.pro)
-+if(GRIB)
-+ add_test(test_grib.pro ${LAUNCHTESTLOCATION} test_grib.pro)
-+endif(GRIB)
-+add_test(test_hist_2d.pro ${LAUNCHTESTLOCATION} test_hist_2d.pro)
-+add_test(test_idl8.pro ${LAUNCHTESTLOCATION} test_idl8.pro)
-+add_test(test_idl_validname.pro ${LAUNCHTESTLOCATION} test_idl_validname.pro)
-+add_test(test_interpol.pro ${LAUNCHTESTLOCATION} test_interpol.pro)
-+add_test(test_interpolate_missing.pro ${LAUNCHTESTLOCATION} test_interpolate_missing.pro)
-+# Needs MEMORY(), not working on Linux
-+# add_test(test_memory.pro ${LAUNCHTESTLOCATION} test_memory.pro)
-+# add_test(test_fft_leak.pro ${LAUNCHTESTLOCATION} test_fft_leak.pro)
-+add_test(test_moment.pro ${LAUNCHTESTLOCATION} test_moment.pro)
-+# mpfit disabled because needs external non required library
-+# add_test(test_mpfit.pro ${LAUNCHTESTLOCATION} test_mpfit.pro)
-+add_test(test_multiroots.pro ${LAUNCHTESTLOCATION} test_multiroots.pro)
-+add_test(test_nestedloop.pro ${LAUNCHTESTLOCATION} test_nestedloop.pro)
-+add_test(test_plotting_ranges.pro ${LAUNCHTESTLOCATION} test_plotting_ranges.pro)
-+add_test(test_pmulti.pro ${LAUNCHTESTLOCATION} test_pmulti.pro)
-+add_test(test_product.pro ${LAUNCHTESTLOCATION} test_product.pro)
-+add_test(test_ps_decomposed.pro ${LAUNCHTESTLOCATION} test_ps_decomposed.pro)
-+if(PYTHON)
-+ add_test(test_python.pro ${LAUNCHTESTLOCATION} test_python.pro)
-+endif(PYTHON)
-+if(PYTHON_MODULE)
-+ add_test(test_python_module_0.pro ${LAUNCHTESTLOCATION} test_python_module_0.pro)
-+ add_test(test_python_module_1.pro ${LAUNCHTESTLOCATION} test_python_module_1.pro)
-+ add_test(test_python_module_2.pro ${LAUNCHTESTLOCATION} test_python_module_2.pro)
-+endif(PYTHON_MODULE)
-+add_test(test_readf.pro ${LAUNCHTESTLOCATION} test_readf.pro)
-+add_test(test_rebin.pro ${LAUNCHTESTLOCATION} test_rebin.pro)
-+add_test(test_rk4.pro ${LAUNCHTESTLOCATION} test_rk4.pro)
-+add_test(test_scope_varfetch.pro ${LAUNCHTESTLOCATION} test_scope_varfetch.pro)
-+add_test(test_sem.pro ${LAUNCHTESTLOCATION} test_sem.pro)
-+add_test(test_spawn_unit.pro ${LAUNCHTESTLOCATION} test_spawn_unit.pro)
-+add_test(test_spher_harm.pro ${LAUNCHTESTLOCATION} test_spher_harm.pro)
-+add_test(test_spl_init.pro ${LAUNCHTESTLOCATION} test_spl_init.pro)
-+add_test(test_step.pro ${LAUNCHTESTLOCATION} test_step.pro)
-+add_test(test_str_functions.pro ${LAUNCHTESTLOCATION} test_str_functions.pro)
-+add_test(test_str_sep.pro ${LAUNCHTESTLOCATION} test_str_sep.pro)
-+add_test(test_stregex.pro ${LAUNCHTESTLOCATION} test_stregex.pro)
-+add_test(test_strsplit.pro ${LAUNCHTESTLOCATION} test_strsplit.pro)
-+add_test(test_suite.pro ${LAUNCHTESTLOCATION} test_suite.pro)
-+add_test(test_systime.pro ${LAUNCHTESTLOCATION} test_systime.pro)
-+add_test(test_url.pro ${LAUNCHTESTLOCATION} test_url.pro)
-+add_test(test_wavelet.pro ${LAUNCHTESTLOCATION} test_wavelet.pro)
-+add_test(test_zeropoly.pro ${LAUNCHTESTLOCATION} test_zeropoly.pro)
-+add_test(test_zip.pro ${LAUNCHTESTLOCATION} test_zip.pro)
diff --git a/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch b/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch
deleted file mode 100644
index 42f401fcf5af..000000000000
--- a/dev-lang/gdl/files/0.9.3-netcdf-cxx.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- CMakeModules/FindNetCDF.cmake.orig 2013-01-03 11:27:52.373435387 -0800
-+++ CMakeModules/FindNetCDF.cmake 2013-01-03 12:23:04.710333638 -0800
-@@ -9,16 +9,27 @@
- #
-
-
--find_path(NETCDFPKG netcdf.pc PATH_SUFFIXES lib lib/pkgconfig)
-+find_path(NETCDFPKG netcdf-cxx4.pc PATH_SUFFIXES lib lib/pkgconfig)
-+if(NETCDFPKG)
-+ set(netcdfpc netcdf-cxx4)
-+else(NETCDFPKG)
-+ find_path(NETCDFPKG netcdf.pc PATH_SUFFIXES lib lib/pkgconfig)
-+ set(netcdfpc netcdf)
-+endif(NETCDFPKG)
-+
- include(FindPackageHandleStandardArgs)
- if(NETCDFPKG)
- set(ENV{PKG_CONFIG_PATH} ${NETCDFPKG}) # pkg search path
- include(FindPkgConfig)
-- pkg_check_modules(NETCDF netcdf)
-+ pkg_check_modules(NETCDF ${netcdfpc})
- if(NETCDF_FOUND)
-- find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
-+ if(NETCDF_INCLUDE_DIRS)
-+ find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
-+ else(NETCDF_INCLUDE_DIRS)
-+ find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES)
-+ endif(NETCDF_INCLUDE_DIRS)
- endif(NETCDF_FOUND)
--else(NETCDFPKG) # no netcdf.pc file
-+else(NETCDFPKG) # no pc file. assume netcdf-3
- find_library(NETCDF_LIBRARIES NAMES netcdf)
- find_path(NETCDF_INCLUDE_DIRS NAMES netcdfcpp.h PATH_SUFFIXES netcdf-3)
- find_package_handle_standard_args(NETCDF DEFAULT_MSG NETCDF_LIBRARIES NETCDF_INCLUDE_DIRS)
diff --git a/dev-lang/gdl/files/0.9.3-sstream.patch b/dev-lang/gdl/files/0.9.3-sstream.patch
deleted file mode 100644
index 77322d00a074..000000000000
--- a/dev-lang/gdl/files/0.9.3-sstream.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/magick_cl.cpp.orig 2013-01-02 13:39:02.387184167 -0800
-+++ src/magick_cl.cpp 2013-01-02 13:40:14.876543262 -0800
-@@ -30,6 +30,7 @@
- #include <string>
- #include <fstream>
- #include <memory>
-+#include <sstream>
- //#include <Magick++.h>
-
- #include "datatypes.hpp"
-@@ -57,25 +58,17 @@
-
- string GDLutos(unsigned int i)
- {
-- int mema=3;
-- char *n=new char(mema);
-- while (snprintf(n, sizeof n, "%u", i) >= sizeof n)
-- { delete n;mema++; n=new char(mema); }
-- string s=n;
-- delete n;
-- return s;
-+ istringstream s;
-+ s >> i;
-+ return s.str();
- }
-
-
- string GDLitos(int i)
- {
-- int mema=3;
-- char *n=new char(mema);
-- while (snprintf(n, sizeof n, "%d", i) >= sizeof n)
-- { delete n;mema++; n=new char(mema); }
-- string s=n;
-- delete n;
-- return s;
-+ istringstream s;
-+ s >> i;
-+ return s.str();
- }
-
-