summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/oro/oro-2.0.7.ebuild')
-rw-r--r--dev-java/oro/oro-2.0.7.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/dev-java/oro/oro-2.0.7.ebuild b/dev-java/oro/oro-2.0.7.ebuild
index 2ded54566df3..8b7ddb1f050f 100644
--- a/dev-java/oro/oro-2.0.7.ebuild
+++ b/dev-java/oro/oro-2.0.7.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.3 2003/07/11 21:41:54 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.4 2003/08/05 18:53:42 vapier Exp $
-S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( >=dev-java/jikes-1.17 )"
-REDEPND=">=virtual/jdk-1.3"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
src_compile() {
local myc
@@ -29,14 +32,11 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
mv jakarta-oro*.jar oro.jar
dojar oro.jar || die "Failed Installing"
dodoc CHANGES COMPILE CONTRIBUTORS ISSUES LICENSE README STYLE TODO
dohtml *.html
- if [ -n "`use doc`" ] ; then
- dodir /usr/share/doc/${P}
- dohtml -r docs/
- fi
+ [ -n "`use doc`" ] && dohtml -r docs/
}