summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dash/dash-0.5.3.7.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.3.7.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-shells/dash/dash-0.5.3.7.ebuild b/app-shells/dash/dash-0.5.3.7.ebuild
deleted file mode 100644
index 25d76498e9f3..000000000000
--- a/app-shells/dash/dash-0.5.3.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7.ebuild,v 1.7 2007/04/18 17:48:01 nixnut Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DEB_PV=${PV%.*}
-DEB_PATCH=${PV##*.}
-DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
-MY_P="${PN}-${DEB_PV}"
-
-DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the
-Almquist SHell) and is POSIX compliant"
-HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz \
- mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="static"
-
-DEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}/${DEB_PF}".diff
-
- # Below patch sorts the builtincmd structure correctly when LC_ALL isn't C
- epatch "${FILESDIR}/${MY_P}"-sort-locale.patch
-}
-
-src_compile() {
- use static && append-ldflags -static
-
- export CC="$(tc-getCC)"
- econf || die "econf failed"
- emake CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- exeinto /bin
- newexe src/dash dash
- newman src/dash.1 dash.1
- dodoc COPYING ChangeLog
-}