summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pysmssend/pysmssend-1.42.ebuild')
-rw-r--r--app-misc/pysmssend/pysmssend-1.42.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/pysmssend/pysmssend-1.42.ebuild b/app-misc/pysmssend/pysmssend-1.42.ebuild
new file mode 100644
index 000000000000..076b3ac2bbab
--- /dev/null
+++ b/app-misc/pysmssend/pysmssend-1.42.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pysmssend/pysmssend-1.42.ebuild,v 1.1 2009/10/16 20:52:14 hwoarang Exp $
+
+NEED_PYTHON=2.5
+
+EAPI="2"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Python Application for sending sms over multiple ISPs"
+HOMEPAGE="http://pysmssend.silverarrow.org/"
+SRC_URI="mirror://www.silverarrow.org/projects/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+RDEPEND=">dev-python/mechanize-0.1.7b
+ qt4? ( dev-python/PyQt4[X] )"
+
+src_install() {
+ distutils_src_install
+ if use qt4; then
+ insinto /usr/share/${PN}/Icons || die "insinto failed"
+ doins Icons/* || die "doins failed"
+ doicon Icons/pysmssend.png || die "doicon failed"
+ dobin pysmssend pysmssendcmd || die "failed to create executables"
+ make_desktop_entry pysmssend pySMSsend pysmssend.png \
+ "Applications;Network" || die "make_desktop_entry failed"
+ else
+ dobin pysmssendcmd || die "failed to create executable"
+ dosym pysmssendcmd /usr/bin/pysmssend || die "dosym failed"
+ fi
+ dodoc README AUTHORS TODO || die "dodoc failed"
+}