summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild')
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
index ad0b25967502..c0cc8625a100 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild,v 1.2 2014/05/31 18:48:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild,v 1.3 2014/07/27 18:00:13 ssuominen Exp $
EAPI="4"
@@ -9,12 +9,19 @@ inherit leechcraft
DESCRIPTION="UPower-based power manager for LeechCraft"
SLOT="0"
-KEYWORDS=" ~amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- || ( sys-power/upower sys-power/upower-pm-utils )
x11-libs/qwt:6
dev-qt/qtdbus:4
virtual/leechcraft-trayarea"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )"
+
+pkg_postinst() {
+ if has_version '>=sys-power/upower-0.99'; then
+ ewarn "If you need hibernate and suspend support, you need to downgrade"
+ ewarn "sys-power/upower to 0.9.23 or switch to sys-power/upower-pm-utils"
+ fi
+}