summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/tpb/tpb-0.6.2.ebuild')
-rw-r--r--app-laptop/tpb/tpb-0.6.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-laptop/tpb/tpb-0.6.2.ebuild b/app-laptop/tpb/tpb-0.6.2.ebuild
new file mode 100644
index 000000000000..0cddbaf49e61
--- /dev/null
+++ b/app-laptop/tpb/tpb-0.6.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpb/tpb-0.6.2.ebuild,v 1.1 2004/06/11 14:52:48 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="Thinkpad button utility"
+HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
+SRC_URI="http://savannah.nongnu.org/download/tpb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="x11-libs/xosd"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-configure-fix.diff
+}
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README ChangeLog CREDITS doc/{nvram.txt,callback_example.sh}
+}
+
+pkg_postinst() {
+ einfo "tpb requires you to have nvram support compiled into"
+ einfo "your kernel to function."
+}