summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.5.30.ebuild')
-rw-r--r--app-emulation/wine/wine-1.5.30.ebuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/app-emulation/wine/wine-1.5.30.ebuild b/app-emulation/wine/wine-1.5.30.ebuild
index 3c081f8f0f31..aac2f87d3bb5 100644
--- a/app-emulation/wine/wine-1.5.30.ebuild
+++ b/app-emulation/wine/wine-1.5.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.30.ebuild,v 1.6 2013/09/01 14:38:32 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.30.ebuild,v 1.7 2013/10/13 21:10:09 tetromino Exp $
EAPI="5"
@@ -142,17 +142,32 @@ usr/share/applications/wine-notepad.desktop
usr/share/applications/wine-uninstaller.desktop
usr/share/applications/wine-winecfg.desktop"
-src_unpack() {
- if use abi_x86_64; then
- [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
- && die "you need gcc-4.4+ to build 64bit wine"
+wine_build_environment_check() {
+ [[ ${MERGE_TYPE} = "binary" ]] && return 0
+
+ if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
+ eerror "You need gcc-4.4+ to build 64-bit wine"
+ eerror
+ return 1
fi
- if use abi_x86_32 && use opencl; then
- [[ x$(eselect opencl show) = "xintel" ]] &&
- die "Cannot build wine[opencl,abi_x86_32]: intel-ocl-sdk is 64-bit only" # 403947
+ if use abi_x86_32 && use opencl && [[ x$(eselect opencl show 2> /dev/null) = "xintel" ]]; then
+ eerror "You cannot build wine with USE=opencl because intel-ocl-sdk is 64-bit only."
+ eerror "See https://bugs.gentoo.org/487864 for more details."
+ eerror
+ return 1
fi
+}
+
+pkg_pretend() {
+ wine_build_environment_check || die
+}
+
+pkg_setup() {
+ wine_build_environment_check || die
+}
+src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-2_src_unpack
else