summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/highline/highline-6.1.ebuild')
-rw-r--r--app-emacs/highline/highline-6.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/highline/highline-6.1.ebuild b/app-emacs/highline/highline-6.1.ebuild
new file mode 100644
index 000000000000..6a44704028e0
--- /dev/null
+++ b/app-emacs/highline/highline-6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/highline/highline-6.1.ebuild,v 1.1 2008/01/22 08:10:28 opfer Exp $
+
+inherit elisp
+
+DESCRIPTION="Minor mode to highlight current line in buffer"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/HighlineMode"
+# taken from: http://www.emacswiki.org/cgi-bin/emacs/download/${PN}.el
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE=""
+
+SIMPLE_ELISP=t
+SITEFILE=51${PN}-gentoo.el
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ elisp-make-autoload-file || die "elisp-make-autoload-file failed"
+}