summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild')
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild
index 837a800c1fb6..4e720148bceb 100644
--- a/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild
+++ b/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild,v 1.5 2005/08/07 00:24:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha01-r2.ebuild,v 1.6 2005/10/01 16:47:12 metalgod Exp $
inherit eutils gnuconfig toolchain-funcs flag-o-matic
@@ -59,7 +59,15 @@ src_unpack() {
src_compile() {
gnuconfig_update
- use unicode && append-flags "-finput-charset=ISO-8859-1 -fexec-charset=UTF-8"
+ if use unicode; then
+ local flags="$(test_flag -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
+ if [[ -n ${flags} ]]; then
+ append-flags ${flags}
+ else
+ ewarn "Your compiler does not support the options required to build"
+ ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
+ fi
+ fi
emake CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die
}