summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdemu/cdemu-0.5.3.ebuild')
-rw-r--r--app-cdr/cdemu/cdemu-0.5.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-cdr/cdemu/cdemu-0.5.3.ebuild b/app-cdr/cdemu/cdemu-0.5.3.ebuild
new file mode 100644
index 000000000000..844fe95e332c
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-0.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc., 2002-2003 Mike Frysinger
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-0.5.3.ebuild,v 1.1 2003/09/18 17:01:46 vapier Exp $
+
+inherit gcc
+
+MY_P=${PN}_${PV}
+DESCRIPTION="mount bin/cue cd images"
+HOMEPAGE="http://robert.private.outertech.com/virtualcd/"
+SRC_URI="http://robert.private.outertech.com/virtualcd/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/kernel"
+RDEPEND="dev-lang/python"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if [ "${KV:0:3}" != "2.4" ] ; then
+ die "This package only works with 2.4.x kernels"
+ else
+ true
+ fi
+}
+
+src_compile() {
+ $(gcc-getCC) -c cdemu.c -o cdemu.o \
+ ${CFLAGS} -D__KERNEL__ -DMODULE -Wall \
+ -I/usr/src/linux/include \
+ || die "could not make kernel module"
+}
+
+src_install() {
+ dobin cdemu
+ insinto /usr/lib/python2.2/site-packages
+ doins libcdemu.py
+
+ insinto /lib/modules/${KV}/kernel/fs/cdemu
+ doins cdemu.o
+
+ dodoc AUTHORS ChangeLog README TODO
+}