summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/libc-bench/libc-bench-20110206.ebuild')
-rw-r--r--app-benchmarks/libc-bench/libc-bench-20110206.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
index ce84adc97005..d46794b4fd25 100644
--- a/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
+++ b/app-benchmarks/libc-bench/libc-bench-20110206.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/libc-bench-20110206.ebuild,v 1.1 2013/06/21 14:19:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/libc-bench/libc-bench-20110206.ebuild,v 1.2 2014/04/03 20:58:19 vapier Exp $
EAPI="5"
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Time and memory-efficiency tests of various C/POSIX standard library functions"
-HOMEPAGE="http://www.etalabs.net/libc-bench.html"
+HOMEPAGE="http://www.etalabs.net/libc-bench.html http://git.musl-libc.org/cgit/libc-bench/"
SRC_URI="http://www.etalabs.net/releases/${P}.tar.gz"
LICENSE="MIT"
@@ -15,14 +15,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
src_prepare() {
epatch "${FILESDIR}"/respect-flags.patch
}
+src_configure() {
+ tc-export CC
+ CFLAGS+=" ${CPPFLAGS}"
+}
+
src_install() {
- exeinto /usr/bin
- doexe libc-bench
+ dobin libc-bench
}