summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/openldap/files/digest1
-rwxr-xr-xnet-nds/openldap/files/slapd29
-rwxr-xr-xnet-nds/openldap/files/slurpd29
-rw-r--r--net-nds/openldap/openldap-1.2.11-r1.ebuild53
-rw-r--r--net-nds/portmap/files/digest1
-rwxr-xr-xnet-nds/portmap/files/portmap28
-rw-r--r--net-nds/portmap/files/portmap_5beta.dif294
-rw-r--r--net-nds/portmap/portmap-5b-r1.ebuild47
-rw-r--r--net-nds/yp-tools/files/digest1
-rw-r--r--net-nds/yp-tools/yp-tools-2.4-r1.ebuild36
-rw-r--r--net-nds/ypbind/files/digest1
-rwxr-xr-xnet-nds/ypbind/files/ypbind38
-rw-r--r--net-nds/ypbind/ypbind-1.6-r1.ebuild34
-rw-r--r--net-nds/ypserv/files/defs.sed30
-rw-r--r--net-nds/ypserv/files/digest1
-rwxr-xr-xnet-nds/ypserv/files/ypserv30
-rw-r--r--net-nds/ypserv/ypserv-1.3.9-r1.ebuild64
17 files changed, 717 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest b/net-nds/openldap/files/digest
new file mode 100644
index 000000000000..cb3f745c984b
--- /dev/null
+++ b/net-nds/openldap/files/digest
@@ -0,0 +1 @@
+MD5 ac469c0fe66ece3893e96182f14b7886 openldap-1.2.11.tgz
diff --git a/net-nds/openldap/files/slapd b/net-nds/openldap/files/slapd
new file mode 100755
index 000000000000..c0c81f546b7e
--- /dev/null
+++ b/net-nds/openldap/files/slapd
@@ -0,0 +1,29 @@
+#!/bin/sh
+#RCUPDATE:3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE=ldap-server
+EXE="/usr/libexec/openldap/slapd"
+opts="start stop restart"
+
+start() {
+ ebegin "Starting ${SERVICE}"
+ start-stop-daemon --start --quiet --exec $EXE 1>&2
+ eend $? "Error starting ${SERVICE}."
+}
+
+stop() {
+ ebegin "Stopping ${SERVICE}"
+ start-stop-daemon --stop --quiet --exec $EXE 1>&2
+ eend $? "Error stopping ${SERVICE}."
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
diff --git a/net-nds/openldap/files/slurpd b/net-nds/openldap/files/slurpd
new file mode 100755
index 000000000000..cc25619568e6
--- /dev/null
+++ b/net-nds/openldap/files/slurpd
@@ -0,0 +1,29 @@
+#!/bin/sh
+#RCUPDATE:3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE=slurpd
+EXE="/usr/libexec/openldap/slurpd"
+opts="start stop restart"
+
+start() {
+ ebegin "Starting ${SERVICE}"
+ start-stop-daemon --start --quiet --exec $EXE 1>&2
+ eend $? "Error starting ${SERVICE}."
+}
+
+stop() {
+ ebegin "Stopping ${SERVICE}"
+ start-stop-daemon --stop --quiet --exec $EXE 1>&2
+ eend $? "Error stopping ${SERVICE}."
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
diff --git a/net-nds/openldap/openldap-1.2.11-r1.ebuild b/net-nds/openldap/openldap-1.2.11-r1.ebuild
new file mode 100644
index 000000000000..fb858e7a5eb1
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.11-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=openldap-1.2.11
+A=${P}.tgz
+S=${WORKDIR}/${P}
+CATEGORY="net-nds"
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ make depend
+ make
+ cd tests
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/state install
+ prepman
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}
+
+
+
+
+
diff --git a/net-nds/portmap/files/digest b/net-nds/portmap/files/digest
new file mode 100644
index 000000000000..9f8af7776dc1
--- /dev/null
+++ b/net-nds/portmap/files/digest
@@ -0,0 +1 @@
+MD5 781e16ed4487c4caa082c6fef09ead4f portmap_5beta.tar.gz
diff --git a/net-nds/portmap/files/portmap b/net-nds/portmap/files/portmap
new file mode 100755
index 000000000000..2be2a499eea5
--- /dev/null
+++ b/net-nds/portmap/files/portmap
@@ -0,0 +1,28 @@
+#!/bin/sh
+#RCUPDATE:3 4:72:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE=portmap
+EXE="/sbin/portmap"
+opts="start stop restart"
+
+start() {
+ ebegin "Starting ${SERVICE}"
+ start-stop-daemon --start --quiet --exec $EXE 1>&2
+ eend $? "Error starting ${SERVICE}."
+}
+
+stop() {
+ ebegin "Stopping ${SERVICE}"
+ start-stop-daemon --stop --quiet --exec $EXE 1>&2
+ eend $? "Error stopping ${SERVICE}."
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
diff --git a/net-nds/portmap/files/portmap_5beta.dif b/net-nds/portmap/files/portmap_5beta.dif
new file mode 100644
index 000000000000..23ce5f14560f
--- /dev/null
+++ b/net-nds/portmap/files/portmap_5beta.dif
@@ -0,0 +1,294 @@
+--- from_local.c
++++ from_local.c 2000/02/28 15:10:25
+@@ -46,6 +46,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <net/if.h>
+--- Makefile
++++ Makefile 2000/02/28 15:10:25
+@@ -8,7 +8,7 @@
+ # if you disagree. See `man 3 syslog' for examples. Some syslog versions
+ # do not provide this flexibility.
+ #
+-FACILITY=LOG_MAIL
++FACILITY=LOG_AUTH
+
+ # To disable tcp-wrapper style access control, comment out the following
+ # macro definitions. Access control can also be turned off by providing
+@@ -71,7 +71,7 @@
+ # With verbose logging on, HP-UX 9.x and AIX 4.1 leave zombies behind when
+ # SIGCHLD is not ignored. Enable next macro for a fix.
+ #
+-# ZOMBIES = -DIGNORE_SIGCHLD # AIX 4.x, HP-UX 9.x
++ZOMBIES = -DIGNORE_SIGCHLD # AIX 4.x, HP-UX 9.x
+
+ # Uncomment the following macro if your system does not have u_long.
+ #
+@@ -81,11 +81,15 @@
+ # libwrap.a object library. WRAP_DIR should specify the directory with
+ # that library.
+
+-WRAP_DIR= ../tcp_wrappers
++WRAP_DIR= /usr/lib
+
+ # Auxiliary object files that may be missing from your C library.
+ #
+-AUX = daemon.o strerror.o
++AUX = # daemon.o strerror.o
++
++LIBS = -lwrap -lutil
++NSARCHS =
++O = -Wall -O2 -pipe
+
+ # NEXTSTEP is a little different. The following seems to work with NS 3.2
+ #
+@@ -99,7 +103,7 @@
+
+ # Comment out if your compiler talks ANSI and understands const
+ #
+-CONST = -Dconst=
++#CONST = -Dconst=
+
+ ### End of configurable stuff.
+ ##############################
+@@ -109,7 +113,7 @@
+ COPT = $(CONST) -Dperror=xperror $(HOSTS_ACCESS) $(CHECK_PORT) \
+ $(SYS) -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(SA_LEN) \
+ $(LOOPBACK) $(SETPGRP)
+-CFLAGS = $(COPT) -O $(NSARCHS)
++CFLAGS = $(COPT) $(O) $(NSARCHS)
+ OBJECTS = portmap.o pmap_check.o from_local.o $(AUX)
+
+ all: portmap pmap_dump pmap_set
+--- pmap_dump.8
++++ pmap_dump.8 2000/02/28 15:10:25
+@@ -0,0 +1,23 @@
++.TH PMAP_DUMP 8 "21th June 1997" Linux "Linux Programmer's Manual"
++.SH NAME
++pmap_dump \- print a list of all registered RPC programs
++.SH SYNOPSIS
++.B pmap_dump
++.SH DESCRIPTION
++The
++.B pmap_dump
++command can be used to restart a running portmapper or to print
++a list of all registered RPC programs on the local host. If you
++want to use the program to restart the portmapper you have to
++redirect the output of
++.B pmap_dump
++to a file. After this you can restart the portmapper and restore
++the list of the registered RPC programs by feeding the output
++of
++.B pmap_dump
++to the
++.B pmap_set
++command.
++.SH SEE ALSO
++.BR pmap_set (8),
++.BR portmap (8)
+--- pmap_set.8
++++ pmap_set.8 2000/02/28 15:10:25
+@@ -0,0 +1,24 @@
++.TH PMAP_SET 8 "21th June 1997" Linux "Linux Programmer's Manual"
++.SH NAME
++pmap_set \- set the list of registered RPC programs
++.SH SYNOPSIS
++.B pmap_set
++.SH DESCRIPTION
++The
++.B pmap_set
++command can be used to restart a running portmapper or to set
++the list of registered RPC programs on the local host. If you
++want to use the program to restart the portmapper you have to
++redirect the output of
++.B pmap_dump
++to a file. After this you can restart the portmapper and restore
++the list of the registered RPC programs by feeding the output
++of
++.B pmap_dump
++to the
++.B pmap_set
++command.
++.SH SEE ALSO
++.BR pmap_dump (8),
++.BR portmap (8)
++
+--- portmap.8
++++ portmap.8 2000/02/28 15:10:25
+@@ -0,0 +1,158 @@
++.\" Copyright (c) 1987 Sun Microsystems
++.\" Copyright (c) 1990, 1991 The Regents of the University of California.
++.\" All rights reserved.
++.\"
++.\" Redistribution and use in source and binary forms, with or without
++.\" modification, are permitted provided that the following conditions
++.\" are met:
++.\" 1. Redistributions of source code must retain the above copyright
++.\" notice, this list of conditions and the following disclaimer.
++.\" 2. Redistributions in binary form must reproduce the above copyright
++.\" notice, this list of conditions and the following disclaimer in the
++.\" documentation and/or other materials provided with the distribution.
++.\" 3. All advertising materials mentioning features or use of this software
++.\" must display the following acknowledgement:
++.\" This product includes software developed by the University of
++.\" California, Berkeley and its contributors.
++.\" 4. Neither the name of the University nor the names of its contributors
++.\" may be used to endorse or promote products derived from this software
++.\" without specific prior written permission.
++.\"
++.\" THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
++.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++.\" ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
++.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++.\" SUCH DAMAGE.
++.\"
++.\" from: @(#)portmap.8 5.3 (Berkeley) 3/16/91
++.\" $Id: portmap_5beta.dif,v 1.1 2000/08/09 23:55:48 achim Exp $
++.\"
++.Dd March 16, 1991
++.Dt PORTMAP 8
++.Os BSD 4.3
++.Sh NAME
++.Nm portmap
++.Nd
++.Tn DARPA
++port to
++.Tn RPC
++program number mapper
++.Sh SYNOPSIS
++.Nm portmap
++.Op Fl dv
++.Sh DESCRIPTION
++.Nm Portmap
++is a server that converts
++.Tn RPC
++program numbers into
++.Tn DARPA
++protocol port numbers.
++It must be running in order to make
++.Tn RPC
++calls.
++.Pp
++When an
++.Tn RPC
++server is started, it will tell
++.Nm portmap
++what port number it is listening to, and what
++.Tn RPC
++program numbers it is prepared to serve.
++When a client wishes to make an
++.Tn RPC
++call to a given program number,
++it will first contact
++.Nm portmap
++on the server machine to determine
++the port number where
++.Tn RPC
++packets should be sent.
++.Pp
++.Nm Portmap
++must be started before any
++.Tn RPC
++servers are invoked.
++.Pp
++Normally
++.Nm portmap
++forks and dissociates itself from the terminal
++like any other daemon.
++.Nm Portmap
++then logs errors using
++.Xr syslog 3 .
++.Pp
++Option available:
++.Bl -tag -width Ds
++.It Fl d
++(debug) prevents
++.Nm portmap
++from running as a daemon,
++and causes errors and debugging information
++to be printed to the standard error output.
++.It Fl v
++(verbose) causes
++.Nm portmap
++to give more logging information to
++.Xr syslogd 8.
++.Pp
++.Sh Access control
++By default, host access control is enabled. However, the host that runs
++the portmapper is always considered authorized. The host access control
++tables are never consulted with requests from the local system itself;
++they are always consulted with requests from other hosts.
++.Pp
++In order to avoid deadlocks, the portmap program does not attempt to
++look up the remote host name or user name, nor will it try to match NIS
++netgroups. The upshot of all this is that only network number patterns
++will work for portmap access control.
++.Pp
++Sample entries for the host access-control files are:
++
++.Nm /etc/hosts.allow:
++ portmap: your.sub.net.number/your.sub.net.mask
++ portmap: 255.255.255.255 0.0.0.0
++
++.Nm /etc/hosts.deny
++ portmap: ALL
++
++The syntax of the access-control files is described in the
++.Xr hosts_access 5
++and
++.Xr hosts_options 5
++manual page that comes with the tcp wrapper (log_tcp)
++sources. The safe_finger command comes with later wrapper releases.
++.Pp
++The first line in the hosts.allow file permits access from all systems
++within your own subnet. Some rpc services rely on broadcasts and will
++contact your portmapper anyway; and once an intruder has access to your
++local network segment you're already in deep trouble.
++.Pp
++The second line in the hosts.allow file may be needed if there are
++any PC-NFS systems on your network segment.
++.Pp
++For security reasons, the portmap process drops root privilegs after
++initialization. The access control files should therefore be readable
++for group or world.
++.El
++.Sh SEE ALSO
++.Xr inetd.conf 5 ,
++.Xr rpcinfo 8 ,
++.Xr inetd 8 ,
++.Xr syslogd 8 ,
++.Xr hosts_access 5 ,
++.Xr hosts_options 5
++.Sh BUGS
++If
++.Nm portmap
++crashes, all servers must be restarted.
++.Sh HISTORY
++The
++.Nm
++command appeared in
++.Bx 4.3
+--- portmap.c
++++ portmap.c 2000/02/28 15:10:25
+@@ -182,9 +182,8 @@
+ exit(1);
+ }
+
+-#ifdef LOG_MAIL
+- openlog("portmap", debugging ? LOG_PID | LOG_PERROR : LOG_PID,
+- FACILITY);
++#ifdef FACILITY
++ openlog("portmap", debugging ? LOG_PID | LOG_PERROR : LOG_PID, FACILITY);
+ #else
+ openlog("portmap", debugging ? LOG_PID | LOG_PERROR : LOG_PID);
+ #endif
diff --git a/net-nds/portmap/portmap-5b-r1.ebuild b/net-nds/portmap/portmap-5b-r1.ebuild
new file mode 100644
index 000000000000..5818a7c7bba3
--- /dev/null
+++ b/net-nds/portmap/portmap-5b-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/portmap-5b-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=portmap-5b
+A=portmap_5beta.tar.gz
+A0=portmap_5beta.dif
+S=${WORKDIR}/portmap_5beta
+DESCRIPTION="Netkit - portmapper"
+CATEGORY=net-nds
+SRC_URI="ftp://ftp.porcupine.org/pub/security/"${A}
+HOMEPAGE="ftp://ftp.porcupine.org/pub/security/index.html"
+
+src_compile() {
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${O}/files/${A0}
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_install() {
+
+ cd ${S}
+ into /
+ dosbin portmap
+ into /usr
+ dosbin pmap_dump pmap_set
+ doman portmap.8 pmap_dump.8 pmap_set.8
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/portmap ${D}/etc/rc.d/init.d
+ dodoc BLURB CHANGES README
+}
+
+pkg_config() {
+
+ source ${ROOT}/etc/rc.d/config/functions
+
+ einfo "Generating symlinks..."
+ ${ROOT}/usr/sbin/rc-update add portmap
+
+}
diff --git a/net-nds/yp-tools/files/digest b/net-nds/yp-tools/files/digest
new file mode 100644
index 000000000000..e650bc67b2e5
--- /dev/null
+++ b/net-nds/yp-tools/files/digest
@@ -0,0 +1 @@
+MD5 eb8923bc0966e25d536189e4f6664617 yp-tools-2.4.tar.gz
diff --git a/net-nds/yp-tools/yp-tools-2.4-r1.ebuild b/net-nds/yp-tools/yp-tools-2.4-r1.ebuild
new file mode 100644
index 000000000000..642c451f5372
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-2.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/yp-tools-2.4-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=yp-tools-2.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="net-nds"
+DESCRIPTION="NIS Tools"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.uk.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${A}"
+HOMEPAGE="http://www.suse.de/~kukuk/nis/yp-tools/index.html"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp
+ make
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+ prepman
+ dodoc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
+ insinto /etc/yp
+ doins etc/nicknames
+}
+
+
+
diff --git a/net-nds/ypbind/files/digest b/net-nds/ypbind/files/digest
new file mode 100644
index 000000000000..69538539ae69
--- /dev/null
+++ b/net-nds/ypbind/files/digest
@@ -0,0 +1 @@
+MD5 903b483e2434230c63407216380b6fc9 ypbind-mt-1.6.tar.gz
diff --git a/net-nds/ypbind/files/ypbind b/net-nds/ypbind/files/ypbind
new file mode 100755
index 000000000000..dea310acba80
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind
@@ -0,0 +1,38 @@
+#!/bin/sh
+#RCUPDATE:2 3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+. /etc/rc.d/config/basic
+
+SERVICE="NIS Client"
+opts="start stop restart"
+
+EXE="/usr/sbin/ypbind"
+PID="/var/run/ypbind.pid"
+
+start() {
+ domainname ${YP_DOMAIN}
+ ebegin "Starting $SERVICE..."
+ start-stop-daemon --start --quiet --exec $EXE
+ eend $? "Started $SERVICE." "Error Starting $SERVICE."
+}
+
+stop() {
+ ebegin "Stopping $SERVICE..."
+ start-stop-daemon --stop --quiet --signal 9 --pid $PID
+ eend $? "Stopped $SERVICE." "Error Stopping $SERVICE."
+
+ # Remove binding files, if ypbind "forget" it
+ rm -f /var/yp/binding/*
+ rm -f /var/lock/subsys/ypbind
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
+
diff --git a/net-nds/ypbind/ypbind-1.6-r1.ebuild b/net-nds/ypbind/ypbind-1.6-r1.ebuild
new file mode 100644
index 000000000000..56f15a749ca8
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.6-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=ypbind-1.6
+A=ypbind-mt-1.6.tar.gz
+S=${WORKDIR}/ypbind-mt-1.6
+CATEGORY="net-nds"
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/ypbind
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc/yp
+ doins etc/yp.conf
+}
+
+
+
diff --git a/net-nds/ypserv/files/defs.sed b/net-nds/ypserv/files/defs.sed
new file mode 100644
index 000000000000..b0d6dada3766
--- /dev/null
+++ b/net-nds/ypserv/files/defs.sed
@@ -0,0 +1,30 @@
+s|@(PERL)|/usr/bin/perl|g
+s|@(YPPUSH)|/usr/sbin/yppush|g
+s|@(MAKEDBM)|/usr/lib/yp/makedbm|g
+s|@(PASSWD)|/etc/passwd|g
+s|@(GROUP)|/etc/group|g
+s|@(HOSTS)|/etc/hosts|g
+s|@(NETWORKS)|/etc/networks|g
+s|@(PROTOCOLS)|/etc/protocols|g
+s|@(SERVICES)|/etc/services|g
+s|@(RPC)|/etc/rpc|g
+s|@(ALIASES)|/etc/aliases|g
+s|@(AUTO_MASTER)|/etc/auto.master|g
+s|@(AMD_MASTER)|/etc/amd.master|g
+s|@(ETHERS)|/etc/ethers|g
+s|@(SHADOW)|/etc/shadow|g
+s|@(GSHADOW)|/etc/gshadow|g
+s|@(NETGROUP)|/etc/netgroup|g
+s|@(PUBLICKEY)|/etc/publickey|g
+s|@(YPSERVERS)|/etc/ypservers|g
+s|@(MAN5EXT)|5|g
+s|@(MAN8EXT)|8|g
+s|@(MAN5DIR)|/usr/man/man5|g
+s|@(MAN8DIR)|/usr/man/man8|g
+s|@(MANUSER)|root|g
+s|@(MANGROUP)|root|g
+s|@(YPMAPDIR)|/var/yp|g
+s|@(YPBINDIR)|/usr/sbin|g
+s|@(YPLIBDIR)|/usr/lib/yp|g
+s|@(YPMODDIR)|/usr/lib/yp/ypmake|g
+s|@(VERSION)|ypmake 0.11 (built Thu Jul 13 05:17:23 2000)|g
diff --git a/net-nds/ypserv/files/digest b/net-nds/ypserv/files/digest
new file mode 100644
index 000000000000..a86507967e40
--- /dev/null
+++ b/net-nds/ypserv/files/digest
@@ -0,0 +1 @@
+MD5 ecdfccf57c3bf0bbba2fe36cdd1fea27 ypserv-1.3.9.tar.gz
diff --git a/net-nds/ypserv/files/ypserv b/net-nds/ypserv/files/ypserv
new file mode 100755
index 000000000000..d7c54817245a
--- /dev/null
+++ b/net-nds/ypserv/files/ypserv
@@ -0,0 +1,30 @@
+#!/bin/sh
+#RCUPDATE:2 3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE="NIS Server"
+opts="start stop restart"
+
+EXE=/usr/sbin/ypserv
+
+start() {
+ ebegin "Starting $SERVICE..."
+ start-stop-daemon --start --quiet --exec $EXE
+ eend $? "Started $SERVICE." "Error Starting $SERVICE."
+}
+
+stop() {
+ ebegin "Stopping $SERVICE..."
+ start-stop-daemon --stop --quiet --exec $EXE
+ eend $? "Stopped $SERVICE." "Error Stopping $SERVICE."
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
diff --git a/net-nds/ypserv/ypserv-1.3.9-r1.ebuild b/net-nds/ypserv/ypserv-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..87dfb0e65bd3
--- /dev/null
+++ b/net-nds/ypserv/ypserv-1.3.9-r1.ebuild
@@ -0,0 +1,64 @@
+## Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-1.3.9-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=ypserv-1.3.9
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="net-nds"
+DESCRIPTION="NIS SERVER"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.uk.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${A}"
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypserv/index.html"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${O}/files/defs.sed ypmake
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp \
+ --localstatedir=/var --enable-tcp-wrapper \
+ --enable-yppasswd
+ make
+ cd ${S}/ypmake
+ sed -f defs.sed Makefile.in > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr YPMAPDIR=${D}/var/yp CONFDIR=${D}/etc/yp \
+ installdirs install_progs
+ prepman
+
+ exeinto /usr/sbin
+ cd ${S}/contrib
+ doexe ypslave
+ cd ${S}/ypmake
+ doexe ypmake
+ insinto /usr/lib/yp/ypmake
+ for i in aliases arrays automount config ethers group gshadow hosts \
+ netgroup netid networks passwd protocols publickey \
+ rpc services shadow ypservers
+ do
+ doins $i
+ done
+ insinto /var/yp
+ doins ypmake.conf.sample
+ newman ypmake.man ypmake.8
+ newman ypmake.conf.man ypmake.conf.5
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/ypserv
+ cd ${S}
+ dodoc BUGS ChangeLog HOWTO.SuSE NEWS TODO
+ insinto /etc/yp
+ doins etc/ypserv.conf
+}
+
+
+