summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/x86info/Manifest5
-rw-r--r--sys-apps/x86info/files/digest-x86info-1.12b1
-rw-r--r--sys-apps/x86info/metadata.xml8
-rw-r--r--sys-apps/x86info/x86info-1.12b.ebuild61
4 files changed, 73 insertions, 2 deletions
diff --git a/sys-apps/x86info/Manifest b/sys-apps/x86info/Manifest
index d2342c6eec19..3d8f9eab9e0d 100644
--- a/sys-apps/x86info/Manifest
+++ b/sys-apps/x86info/Manifest
@@ -1,6 +1,7 @@
MD5 1b17e8a12aac9c2772dceae043544278 x86info-1.11.ebuild 1831
-MD5 43d2ef3c896655051e274f7a7d3c82cf x86info-1.12b.ebuild 1735
-MD5 1b9b0b2634d36d26768d05363fbf90db ChangeLog 508
+MD5 7c18b55fbcdb4cd0b6facd0d1ac67248 x86info-1.12b.ebuild 1881
+MD5 c13bf960f10bb9f0607cb930a156bbd3 ChangeLog 678
+MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
MD5 1759a81bcf65ea2266520c18b934df09 files/digest-x86info-1.12b 61
MD5 14514d85680a44ebe1a0625f76262b3a files/digest-x86info-1.11 60
MD5 122c0e16e774e475d6f37c309e1838e4 files/x86info-modules.conf-rc 326
diff --git a/sys-apps/x86info/files/digest-x86info-1.12b b/sys-apps/x86info/files/digest-x86info-1.12b
new file mode 100644
index 000000000000..4886efcee6e3
--- /dev/null
+++ b/sys-apps/x86info/files/digest-x86info-1.12b
@@ -0,0 +1 @@
+MD5 4f0ce10a00db5778b16a09f68f5f6767 x86info-1.12b.tgz 54200
diff --git a/sys-apps/x86info/metadata.xml b/sys-apps/x86info/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/sys-apps/x86info/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/x86info/x86info-1.12b.ebuild b/sys-apps/x86info/x86info-1.12b.ebuild
new file mode 100644
index 000000000000..af8c2f0d3039
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.12b.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.12b.ebuild,v 1.1 2003/11/15 01:44:43 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/${PN}/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 -ppc -sparc -mips -alpha -arm -hppa"
+DEPEND="virtual/kernel"
+RDEPEND=""
+IUSE=""
+S=${WORKDIR}/${P}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # binaries first
+ into /usr
+ dobin x86info
+ # modules stuff next
+ insinto /etc/modules.d
+ newins ${FILESDIR}/x86info-modules.conf-rc x86info
+ # now we all all the docs
+ dodoc TODO README COPYING ChangeLog
+ doman x86info.1
+ cp -a results ${D}/usr/share/doc/${PF}
+ # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+ # copied from media-libs/svgalib/svgalib-1.9.17
+ if [ "${ROOT}" = "/" ]; then
+ /sbin/modules-update &> /dev/null
+
+ # create device nodes for x86info
+ # based off the scripts/makenode
+ # there isn't any proper devfs support in cpuid/msr
+ einfo "Creating device nodes for x86info"
+ mkdir -p ${ROOT}/dev/cpu
+ local numprocs
+ #subtract one because we are using a 0-based count
+ numprocs=$((`grep -c '^processor' /proc/cpuinfo`-1))
+ for i in `seq 0 $numprocs`; do
+ mkdir ${ROOT}/dev/cpu/$i
+ mknod ${ROOT}/dev/cpu/$i/cpuid c 203 $i 2>/dev/null
+ mknod ${ROOT}/dev/cpu/$i/msr c 202 $i 2>/dev/null
+ done
+ fi
+}