summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/abiword/abiword-2.4.6.ebuild12
-rw-r--r--app-office/eqe/eqe-1.3.0.ebuild16
-rw-r--r--app-office/ooextras/ooextras-20050216.ebuild6
-rw-r--r--app-office/ooextras/ooextras-20060909.ebuild4
4 files changed, 18 insertions, 20 deletions
diff --git a/app-office/abiword/abiword-2.4.6.ebuild b/app-office/abiword/abiword-2.4.6.ebuild
index 6d483237578b..8c55cd86db46 100644
--- a/app-office/abiword/abiword-2.4.6.ebuild
+++ b/app-office/abiword/abiword-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.6.ebuild,v 1.15 2009/01/04 22:51:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.6.ebuild,v 1.16 2009/12/17 10:54:05 ssuominen Exp $
inherit alternatives eutils fdo-mime
@@ -44,8 +44,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/11_history_fullpath.dpatch
- epatch ${FILESDIR}/freebsd_fix.patch
+ epatch "${FILESDIR}"/11_history_fullpath.dpatch
+ epatch "${FILESDIR}"/freebsd_fix.patch
}
src_compile() {
@@ -65,12 +65,12 @@ src_compile() {
src_install() {
dodir /usr/{bin,lib}
- make DESTDIR="${D}" icondir="/usr/share/pixmaps" install || die "install failed"
+ emake DESTDIR="${D}" icondir="/usr/share/pixmaps" install || die "install failed"
dosed "s:Exec=abiword:Exec=abiword-2.4:" /usr/share/applications/abiword.desktop
- rm -f ${D}/usr/bin/abiword
- rm -f ${D}/usr/bin/abiword-2.4
+ rm -f "${D}"/usr/bin/abiword
+ rm -f "${D}"/usr/bin/abiword-2.4
dosym AbiWord-2.4 /usr/bin/abiword-2.4
dodoc *.TXT user/wp/readme.txt
diff --git a/app-office/eqe/eqe-1.3.0.ebuild b/app-office/eqe/eqe-1.3.0.ebuild
index 6146b743780c..d78eea3a5141 100644
--- a/app-office/eqe/eqe-1.3.0.ebuild
+++ b/app-office/eqe/eqe-1.3.0.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/eqe/eqe-1.3.0.ebuild,v 1.3 2009/09/27 12:16:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/eqe/eqe-1.3.0.ebuild,v 1.4 2009/12/17 10:50:45 ssuominen Exp $
inherit eutils
-DESCRIPTION="A small LaTeX editor that produces images, with drag and drop
-support."
+DESCRIPTION="A small LaTeX editor that produces images, with drag and drop support"
HOMEPAGE="http://rlehy.free.fr/"
SRC_URI="http://rlehy.free.fr/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-
IUSE=""
+
DEPEND="dev-perl/gtk2-perl
dev-perl/File-Slurp
dev-perl/Template-Toolkit
@@ -21,13 +20,12 @@ DEPEND="dev-perl/gtk2-perl
virtual/latex-base"
src_unpack() {
- unpack ${A} || die
- cd ${S}
-
+ unpack ${A}
+ cd "${S}"
# Fix install loction and conform to the Gentoo way
- epatch ${FILESDIR}/${P}-Makefile.patch || die
+ epatch "${FILESDIR}"/${P}-Makefile.patch || die
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
}
diff --git a/app-office/ooextras/ooextras-20050216.ebuild b/app-office/ooextras/ooextras-20050216.ebuild
index 0b86f85ff1f9..4b128077e74a 100644
--- a/app-office/ooextras/ooextras-20050216.ebuild
+++ b/app-office/ooextras/ooextras-20050216.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooextras/ooextras-20050216.ebuild,v 1.6 2008/02/25 03:02:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooextras/ooextras-20050216.ebuild,v 1.7 2009/12/17 10:53:02 ssuominen Exp $
DESCRIPTION="OOExtras: Extra Templates for OpenOffice.org!"
HOMEPAGE="http://ooextras.sourceforge.net/"
@@ -22,7 +22,7 @@ src_compile() {
src_install() {
dodir ${INSTDIR}
- cp -R -- ${S}/. ${D}/${INSTDIR}/
+ cp -R -- "${S}"/. "${D}"/${INSTDIR}/
}
pkg_postinst() {
diff --git a/app-office/ooextras/ooextras-20060909.ebuild b/app-office/ooextras/ooextras-20060909.ebuild
index 37fea82172fd..4deba0bb16ae 100644
--- a/app-office/ooextras/ooextras-20060909.ebuild
+++ b/app-office/ooextras/ooextras-20060909.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooextras/ooextras-20060909.ebuild,v 1.5 2009/04/04 14:25:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooextras/ooextras-20060909.ebuild,v 1.6 2009/12/17 10:53:02 ssuominen Exp $
DESCRIPTION="OOExtras: Extra Templates for OpenOffice.org!"
HOMEPAGE="http://ooextras.sourceforge.net/"
@@ -22,7 +22,7 @@ src_compile() {
src_install() {
dodir ${INSTDIR}
- cp -R -- ${S}/. ${D}/${INSTDIR}/
+ cp -R -- "${S}"/. "${D}"/${INSTDIR}/
}
pkg_postinst() {