summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/gnuplot/ChangeLog7
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.7.31
-rw-r--r--media-gfx/gnuplot/gnuplot-3.7.3.ebuild80
3 files changed, 87 insertions, 1 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index c8e917f378d4..79c1d7555747 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.9 2003/02/12 07:01:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.10 2003/03/09 19:57:48 aliz Exp $
+
+*gnuplot-3.7.3 (09 Mar 2003)
+
+ 09 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*gnuplot-3.7.2 (06 Nov 2002)
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.7.3 b/media-gfx/gnuplot/files/digest-gnuplot-3.7.3
new file mode 100644
index 000000000000..fa088ac5cdec
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.7.3
@@ -0,0 +1 @@
+MD5 07921c091153b1f52825fb291849d36d gnuplot-3.7.3.tar.gz 1418889
diff --git a/media-gfx/gnuplot/gnuplot-3.7.3.ebuild b/media-gfx/gnuplot/gnuplot-3.7.3.ebuild
new file mode 100644
index 000000000000..b5ee4daebef1
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.7.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.7.3.ebuild,v 1.1 2003/03/09 19:57:48 aliz Exp $
+
+IUSE="X readline svga plotutils"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Quick and useful plotting program"
+SRC_URI="mirror://sourceforge/gnuplot/${P}.tar.gz"
+HOMEPAGE="http://www.gnuplot.info"
+
+SLOT="0"
+LICENSE="gnuplot"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="media-libs/libpng
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ readline? ( sys-libs/readline )
+ plotutils? ( media-libs/plotutils )"
+
+src_compile() {
+ local myconf
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myconf=" --with-png --without-gd --with-lasergnu"
+ myconf=" --with-png --without-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+
+ use plotutils \
+ && myconf="${myconf} --with-plot=/usr/lib" \
+ || myconf="${myconf} --without-plot"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu" \
+ || myconf="${myconf} --with-readline"
+
+ use svga \
+ && myconf="${myconf} --with-linux-vga" \
+ || myconf="${myconf} --without-linux-vga"
+
+ econf \
+ --datadir=/usr/share/gnuplot \
+ ${myconf} || die
+
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ -e 's/infodir = \/usr/infodir = ${prefix}/' \
+ Makefile.orig > Makefile
+
+ cd docs
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/infodir = \/usr/infodir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ Makefile.orig > Makefile
+
+ cd ${S}
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+
+ dodoc 0* ChangeLog CodeStyle Copyright NEWS PGPKEYS TODO
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ] ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually chmod u+s /usr/bin/gnuplot"
+ fi
+}