summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xnet-misc/openssh/files/sshd18
-rwxr-xr-xnet-misc/openssh/files/sshd-run7
-rw-r--r--net-misc/openssh/openssh-2.3.0_p1-r1.ebuild53
-rwxr-xr-xsys-apps/gluelog/files/klog-run2
-rwxr-xr-xsys-apps/gluelog/files/sysklogd37
-rwxr-xr-xsys-apps/gluelog/files/syslog-run2
-rw-r--r--sys-apps/gluelog/gluelog-1.0.ebuild52
-rw-r--r--x11-libs/openmotif/files/digest-openmotif-2.1.301
8 files changed, 157 insertions, 15 deletions
diff --git a/net-misc/openssh/files/sshd b/net-misc/openssh/files/sshd
index a9427815d1a1..efbe0bf9b379 100755
--- a/net-misc/openssh/files/sshd
+++ b/net-misc/openssh/files/sshd
@@ -3,7 +3,7 @@
. /etc/rc.d/config/functions
-SERVICE="Secure Shell"
+SERVICE="supervised OpenSSH"
opts="start stop restart"
PIDFILE=/var/run/sshd.pid
@@ -11,32 +11,20 @@ EXE=/usr/sbin/sshd
start() {
- if [ ! -e /etc/ssh/ssh_host_key ] ; then
- einfo "Generate Hostkey..."
- /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N ''
- fi
-
- if [ ! -e /etc/ssh/ssh_host_dsa_key ] ; then
- einfo "Generate DSA-Hostkey..."
- /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N ''
- fi
-
ebegin "Starting $SERVICE..."
- start-stop-daemon --start --quiet --exec $EXE
+ /usr/bin/svc -u /etc/svc.d/control/sshd
eend $? "Started $SERVICE." "Error Starting $SERVICE."
}
stop() {
ebegin "Stopping $SERVICE..."
- start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $EXE
+ /usr/bin/svc -d /etc/svc.d/control/sshd
eend $? "Stopped $SERVICE." "Error Stopping $SERVICE."
}
restart() {
-
stop
start
-
}
doservice ${@}
diff --git a/net-misc/openssh/files/sshd-run b/net-misc/openssh/files/sshd-run
new file mode 100755
index 000000000000..7ca410ed8150
--- /dev/null
+++ b/net-misc/openssh/files/sshd-run
@@ -0,0 +1,7 @@
+#!/bin/sh
+if [ ! -e /var/run/sshd.pid ]
+then
+ /usr/sbin/sshd
+ sleep 2
+fi
+exec envuidgid daemon /usr/bin/watchpid `cat /var/run/sshd.pid`
diff --git a/net-misc/openssh/openssh-2.3.0_p1-r1.ebuild b/net-misc/openssh/openssh-2.3.0_p1-r1.ebuild
new file mode 100644
index 000000000000..40d9d94f9a3a
--- /dev/null
+++ b/net-misc/openssh/openssh-2.3.0_p1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.3.0_p1-r1.ebuild,v 1.1 2000/12/10 04:21:36 drobbins Exp $
+
+P=openssh-2.3.0p1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+SRC_URI="ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/"${A}
+HOMEPAGE="http://www.openssh.com/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-apps/tcp-wrappers-7.6
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=dev-libs/openssl-0.9.6"
+
+src_compile() {
+ try ./configure --prefix=/usr --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/libexec --mandir=/usr/man \
+ --enable-gnome-askpass \
+ --with-tcp-wrappers --with-ipv4-default --host=${CHOST}
+ try make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# patch -p0 < contrib/chroot.diff
+}
+
+src_install() {
+ try make manpages install-files DESTDIR=${D}
+ dodoc ChangeLog COPYING.* CREDITS OVERVIEW README* TODO UPGRADING
+ cd ${O}/files
+ insinto /etc/pam.d
+ donewins sshd.pam sshd
+ exeinto /etc/rc.d/init.d
+ doins sshd
+ exeinto /etc/svc.d/services/sshd
+ touch ${D}/etc/svc.d/services/sshd/down
+ newexe ${FILESDIR}/sshd-run run
+}
+
+pkg_postinst() {
+ # Make ssh start at boot
+ echo ">>> Generating symlinks"
+ ${ROOT}/usr/sbin/rc-update add sshd
+}
+
+
+
diff --git a/sys-apps/gluelog/files/klog-run b/sys-apps/gluelog/files/klog-run
new file mode 100755
index 000000000000..499183ce2f89
--- /dev/null
+++ b/sys-apps/gluelog/files/klog-run
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/sbin/glueklog /usr/bin/multilog t /var/log/klog.d
diff --git a/sys-apps/gluelog/files/sysklogd b/sys-apps/gluelog/files/sysklogd
new file mode 100755
index 000000000000..f69975f5d85b
--- /dev/null
+++ b/sys-apps/gluelog/files/sysklogd
@@ -0,0 +1,37 @@
+#!/bin/sh
+#RCUPDATE:1 2 3 4 5:20:This line is required for script management
+
+klog="/usr/sbin/klogd"
+slog="/usr/sbin/syslogd"
+
+. /etc/rc.d/config/functions
+
+SERVICE=sysklogd
+opts="start stop status"
+
+start() {
+ ebegin "Starting supervised syslog and klog"
+ local retval
+ local x
+ retval=0
+
+ for x in klog syslog
+ do
+ /usr/bin/svc -u /etc/svc.d/control/${x}
+ retval=$(( $? + $retval ))
+ done
+ eend $retval
+}
+
+stop() {
+ ebegin "Stopping supervised syslog and klog"
+ /usr/bin/svc -d /etc/svc.d/control/klog /etc/svc.d/control/syslog
+ eend $?
+}
+
+status() {
+ einfo "syslog and klog status:"
+ /usr/bin/svstat /etc/svc.d/control/klog /etc/svc.d/control/syslog
+}
+
+doservice ${@}
diff --git a/sys-apps/gluelog/files/syslog-run b/sys-apps/gluelog/files/syslog-run
new file mode 100755
index 000000000000..fda7b3111c3d
--- /dev/null
+++ b/sys-apps/gluelog/files/syslog-run
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/sbin/gluelog /usr/bin/multilog t /var/log/syslog.d
diff --git a/sys-apps/gluelog/gluelog-1.0.ebuild b/sys-apps/gluelog/gluelog-1.0.ebuild
new file mode 100644
index 000000000000..5db5b44862f2
--- /dev/null
+++ b/sys-apps/gluelog/gluelog-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gluelog/gluelog-1.0.ebuild,v 1.1 2000/12/10 04:21:36 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Pipe and socket fittings for the system and kernel logs"
+SRC_URI=""
+
+src_compile() {
+ mkdir ${S}
+ cd ${FILESDIR}
+ gcc ${CFLAGS} gluelog.c -o ${S}/gluelog
+ gcc ${CFLAGS} glueklog.c -o ${S}/glueklog
+}
+
+src_unpack() {
+ echo
+}
+
+src_install() {
+ dodir /usr/sbin
+ dosbin ${S}/gluelog ${S}/glueklog
+ exeopts -m0750 -g wheel
+ install -d -m0750 -o root -g wheel ${D}/etc/svc.d/control
+ dodir /var/log
+ local x
+ for x in syslog klog
+ do
+ exeinto /etc/svc.d/services/${x}
+ newexe ${FILESDIR}/${x}-run run
+ ln -s ../services/${x} ${D}/etc/svc.d/control/${x}
+ touch ${D}/etc/svc.d/services/${x}/down
+ install -d -m0750 -o daemon -g wheel ${D}/var/log/${x}.d
+ done
+ exeopts -m0755
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/sysklogd
+}
+
+pkg_preinst() {
+ if [ -e ${ROOT}/etc/rc.d/init.d/sysklogd ]
+ then
+ ${ROOT}/etc/rc.d/init.d/sysklogd stop
+ fi
+ ${ROOT}/usr/sbin/rc-update del sysklogd
+}
+
+pkg_postinst() {
+ ${ROOT}/usr/sbin/rc-update add sysklogd
+ ${ROOT}/etc/rc.d/init.d/sysklogd start
+}
diff --git a/x11-libs/openmotif/files/digest-openmotif-2.1.30 b/x11-libs/openmotif/files/digest-openmotif-2.1.30
new file mode 100644
index 000000000000..a44b9d9cae43
--- /dev/null
+++ b/x11-libs/openmotif/files/digest-openmotif-2.1.30
@@ -0,0 +1 @@
+MD5 950f0d409e0ce508fa3995790c1106c7 openmotif-2.1.30-4_MLI.src.tar.gz