summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/bcm43xx/ChangeLog11
-rw-r--r--net-wireless/bcm43xx/Manifest14
-rw-r--r--net-wireless/bcm43xx/bcm43xx-0.0.1-r20060105.ebuild53
-rw-r--r--net-wireless/bcm43xx/files/digest-bcm43xx-0.0.1-r200601051
-rw-r--r--net-wireless/bcm43xx/metadata.xml9
5 files changed, 88 insertions, 0 deletions
diff --git a/net-wireless/bcm43xx/ChangeLog b/net-wireless/bcm43xx/ChangeLog
new file mode 100644
index 000000000000..be49f5e42158
--- /dev/null
+++ b/net-wireless/bcm43xx/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-wireless/bcm43xx
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/ChangeLog,v 1.1 2006/01/05 22:44:38 kugelfang Exp $
+
+*bcm43xx-0.0.1-r20060105 (05 Jan 2006)
+
+ 05 Jan 2006; Danny van Dyk <kugelfang@gentoo.org> +metadata.xml,
+ +bcm43xx-0.0.1-r20060105.ebuild:
+ Added initial ebuild. BCM43xx driver supports (currently) the chipsets
+ BCM4303/06/09/18/XG. Supported network types are 'open' and 'WEP'.
+
diff --git a/net-wireless/bcm43xx/Manifest b/net-wireless/bcm43xx/Manifest
new file mode 100644
index 000000000000..65afeedcfebc
--- /dev/null
+++ b/net-wireless/bcm43xx/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 a726ad0b8acbae811fffe059d2a4442a ChangeLog 501
+MD5 082feebcab8bb5038fe04120e288196f bcm43xx-0.0.1-r20060105.ebuild 1650
+MD5 e5b1323cee6f9ab16ab89fd2d2a89cb9 files/digest-bcm43xx-0.0.1-r20060105 75
+MD5 5c96f35e0e2b1e2ea4e59c21d5a2414c metadata.xml 253
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDvaHD5mJXAu5GbtIRAvZjAJ4kjI2Lblpa0qmEzBvrKEl9pnBueQCaAmIb
+1tlGItBxZ6HVEgUZhrqWJp8=
+=qp2R
+-----END PGP SIGNATURE-----
diff --git a/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060105.ebuild b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060105.ebuild
new file mode 100644
index 000000000000..d2f119fe70b6
--- /dev/null
+++ b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060105.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060105.ebuild,v 1.1 2006/01/05 22:44:38 kugelfang Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Driver for Broadcom 43xx PCI/miniPCI based wireless network devices"
+HOMEPAGE="http://bcm43xx.berlios.de"
+SRC_URI="mirror://gentoo/${PN}-${PVR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+
+IUSE="debug"
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-wireless/ieee80211softmac
+ >=net-wireless/wireless-tools-28_pre4"
+
+BUILD_TARGETS="modules"
+MODULE_NAMES="bcm43xx(net/wireless:)"
+
+CONFIG_CHECK="NET_RADIO FW_LOADER"
+ERROR_NET_RADIO="${P} requires support for \"Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)\"."
+ERROR_FW_LOADER="${P} requires \"Hotplug firmware loading support (CONFIG_FW_LOADER)\"."
+ERROR_IEEE80211="${P} requies (modular) support for \"Generic IEEE 802.11 Networking Stack\"."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is 2 4; then
+ die "${P} does not support building against kernel 2.4.x"
+ fi
+}
+
+src_compile() {
+ BUILD_PARAMS="KSRC=${KV_DIR} KSRC_OUTPUT=${KV_OUT_DIR} SOFTMAC_DIR=/usr/include" linux-mod_src_compile
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if [ -f /lib/modules/${KV_FULL}/net/${PN}.ko ]; then
+ einfo
+ einfo "Modules from an earlier installation detected. You will need to manually"
+ einfo "remove those modules by running the following commands:"
+ einfo " # rm -f /lib/modules/${KV_FULL}/net/${PN}.ko"
+ einfo " # rm -f /lib/modules/${KV_FULL}/net/ieee80211*.ko"
+ einfo " # depmod -a"
+ einfo
+ fi
+}
diff --git a/net-wireless/bcm43xx/files/digest-bcm43xx-0.0.1-r20060105 b/net-wireless/bcm43xx/files/digest-bcm43xx-0.0.1-r20060105
new file mode 100644
index 000000000000..8465ffe83dce
--- /dev/null
+++ b/net-wireless/bcm43xx/files/digest-bcm43xx-0.0.1-r20060105
@@ -0,0 +1 @@
+MD5 f3b205ec9f12d81be9f4ce0d4ccd19a5 bcm43xx-0.0.1-r20060105.tar.bz2 74028
diff --git a/net-wireless/bcm43xx/metadata.xml b/net-wireless/bcm43xx/metadata.xml
new file mode 100644
index 000000000000..a5864a81869b
--- /dev/null
+++ b/net-wireless/bcm43xx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile</herd>
+<maintainer>
+ <email>kugelfang@gentoo.org</email>
+ <name>Danny van Dyk</name>
+</maintainer>
+</pkgmetadata>