summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.mask4
-rw-r--r--sys-devel/bison/ChangeLog10
-rw-r--r--sys-devel/bison/bison-1.35.ebuild55
-rw-r--r--sys-devel/bison/files/digest-bison-1.351
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.2.20.ebuild14
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild22
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild30
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild42
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild7
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild4
10 files changed, 129 insertions, 60 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 920dd7c2c008..37de9717e857 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -22,6 +22,10 @@
## End example
##
+* <seemant@gentoo.org> (09 Aug 2002)
+# masked while azarah approves
+=sys-devel/bison-1.35
+
# <mcummings@gentoo.org> (08 Aug 2002)
# please test - simple address book (bug #6004)
=net-mail/abook-0.4.17
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 05f98b98a244..c209a2fa72d2 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/bison
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.2 2002/04/02 16:16:30 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.3 2002/08/10 03:17:05 seemant Exp $
+
+*bison-1.35 (09 Aug 2002)
+
+ 09 Aug 2002; Seemant Kulleen <seemant@gentoo.org> bison-1.35.ebuild
+ files/digest-bison-1.35 :
+
+ Version bump to newest stable, which fixes issues with the spanish
+ language environment.
*bison-1.34-r1 (2 Apr 2002)
diff --git a/sys-devel/bison/bison-1.35.ebuild b/sys-devel/bison/bison-1.35.ebuild
new file mode 100644
index 000000000000..6ad68acd3364
--- /dev/null
+++ b/sys-devel/bison/bison-1.35.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.1 2002/08/10 03:17:05 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake ${MAKEOPTS} || die
+ else
+ emake ${MAKEOPTS} LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ datadir=/usr/share \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-devel/bison/files/digest-bison-1.35 b/sys-devel/bison/files/digest-bison-1.35
new file mode 100644
index 000000000000..a6f3dce646a1
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-1.35
@@ -0,0 +1 @@
+MD5 e2c06b27f463c6ba19cafbe113d53b1e bison-1.35.tar.gz 770444
diff --git a/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild b/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild
index 8d63a1bceb37..712cf2170f2c 100644
--- a/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild,v 1.5 2002/07/11 06:30:56 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.2.20.ebuild,v 1.6 2002/08/10 03:17:05 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
@@ -21,13 +21,13 @@ PDEVFS=devfs-patch-v99.21
PREISERFS=linux-2.2.19-reiserfs-3.5.34-patch
DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.2/linux-${PV}.tar.bz2
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.2/linux-${PV}.tar.bz2
ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/kernel-patches/v2.2/${PDEVFS}.gz
ftp://ftp.namesys.com/pub/reiserfs-for-2.2/${PREISERFS}.bz2"
PROVIDE="virtual/kernel"
HOMEPAGE="http://www.kernel.org/
- http://www.atnf.csiro.au/~rgooch/linux/kernel-patches.html/
- http://www.namesys.com"
+ http://www.atnf.csiro.au/~rgooch/linux/kernel-patches.html/
+ http://www.namesys.com"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
@@ -60,11 +60,11 @@ src_unpack() {
cd ${S}
make mrproper || die
- #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
+ #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
cp ${S}/arch/i386/defconfig .config || die
yes "" | make oldconfig
echo "Ignore any errors from the yes command above."
-
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 *
diff --git a/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild b/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild
index 93c4fb1dc05b..9bd77ed0d5a5 100644
--- a/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild,v 1.5 2002/07/11 06:30:56 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.2.21_pre3.ebuild,v 1.6 2002/08/10 03:17:05 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
@@ -14,7 +14,7 @@ S=${WORKDIR}/linux-${KV}
# What's in this kernel?
# INCLUDED:
-# Alan Cox's patch-2.2.21-pre3
+# Alan Cox's patch-2.2.21-pre3
# R. Gooch's devfs-patch-v99.21
# Reiserfs linux-2.2.19-reiserfs-3.5.34-patch
@@ -23,14 +23,14 @@ PDEVFS=devfs-patch-v99.21
PREISERFS=linux-2.2.19-reiserfs-3.5.34-patch
DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.2/linux-${OKV}.tar.bz2
- http://www.kernel.org/pub/linux/kernel/v2.2/testing/${PAC}.gz
- ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/kernel-patches/v2.2/${PDEVFS}.gz
- ftp://ftp.namesys.com/pub/reiserfs-for-2.2/${PREISERFS}.bz2"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.2/linux-${OKV}.tar.bz2
+ http://www.kernel.org/pub/linux/kernel/v2.2/testing/${PAC}.gz
+ ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/kernel-patches/v2.2/${PDEVFS}.gz
+ ftp://ftp.namesys.com/pub/reiserfs-for-2.2/${PREISERFS}.bz2"
PROVIDE="virtual/kernel"
HOMEPAGE="http://www.kernel.org/
- http://www.atnf.csiro.au/~rgooch/linux/kernel-patches.html/
- http://www.namesys.com"
+ http://www.atnf.csiro.au/~rgooch/linux/kernel-patches.html/
+ http://www.namesys.com"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
@@ -64,11 +64,11 @@ src_unpack() {
cd ${S}
make mrproper || die
- #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
+ #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
cp ${S}/arch/i386/defconfig .config || die
yes "" | make oldconfig
echo "Ignore any errors from the yes command above."
-
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 *
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild
index 40f4e3422ae2..1504c993fc78 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild,v 1.3 2002/07/11 06:30:56 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r3.ebuild,v 1.4 2002/08/10 03:17:05 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
@@ -16,21 +16,21 @@ KEYWORDS="x86"
#What's in this kernel?
#======================
# EXISTING patches:
-# xfs (26 Jan 2002 CVS)
-# read-latency-2 from akpm (improves multiple disk read/write IO performance)
-# fastpte (enables an option to do fast scanning of the page tables)
-# irqrate-a1 (optimizes irq handling, no more ksoftirqd and eliminates irq storms on servers)
-# ide (from http://www.linuxdiskcert.org, patch ide.2.4.17.01192002.patch) ide updates, performance improvements
-# note: enable "Taskfile" options in kernel config
-# preempt-2.4.17-r1 (preemptible kernel)
-# loopback device deadlock fixes from akpm
+# xfs (26 Jan 2002 CVS)
+# read-latency-2 from akpm (improves multiple disk read/write IO performance)
+# fastpte (enables an option to do fast scanning of the page tables)
+# irqrate-a1 (optimizes irq handling, no more ksoftirqd and eliminates irq storms on servers)
+# ide (from http://www.linuxdiskcert.org, patch ide.2.4.17.01192002.patch) ide updates, performance improvements
+# note: enable "Taskfile" options in kernel config
+# preempt-2.4.17-r1 (preemptible kernel)
+# loopback device deadlock fixes from akpm
# NEW in 2.4.17-r3:
-# acpi-20011205 (ACPI support, new-style power management)
+# acpi-20011205 (ACPI support, new-style power management)
# REMOVED from 2.4.17-r3:
-# readahead patch from akpm (really slowed things down; was mistakenly recommended to me before it was ready)
+# readahead patch from akpm (really slowed things down; was mistakenly recommended to me before it was ready)
DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
PROVIDE="virtual/kernel"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
@@ -65,11 +65,11 @@ src_unpack() {
#sometimes we have icky kernel symbols; this seems to get rid of them
make mrproper || die
- #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
+ #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
cp ${S}/arch/i386/defconfig .config || die
yes "" | make oldconfig
echo "Ignore any errors from the yes command above."
-
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 *
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild
index b321b4d8eec0..1de1c7a1378c 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild,v 1.3 2002/07/11 06:30:56 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.17-r4.ebuild,v 1.4 2002/08/10 03:17:05 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
@@ -16,33 +16,33 @@ KEYWORDS="x86"
# What's in this kernel?
# INCLUDED:
-# xfs (13 Feb 2002 CVS)
-# read-latency2.patch from http://www.zipworld.com.au/~akpm/linux/2.4/2.4.18-pre9/
-# (improves multiple disk read/write IO performance)
-# fastpte
-# (enables an option to do fast scanning of the page tables)
-# ide.2.4.17.02072002.patch from http://www.linuxdiskcert.org/
-# (revamped IDE code)
-# preempt-kernel-rml-2.4.17-3 from http://www.tech9.net/rml/linux/
-# (preemptible kernel)
-# loopback device deadlock fixes from akpm
+# xfs (13 Feb 2002 CVS)
+# read-latency2.patch from http://www.zipworld.com.au/~akpm/linux/2.4/2.4.18-pre9/
+# (improves multiple disk read/write IO performance)
+# fastpte
+# (enables an option to do fast scanning of the page tables)
+# ide.2.4.17.02072002.patch from http://www.linuxdiskcert.org/
+# (revamped IDE code)
+# preempt-kernel-rml-2.4.17-3 from http://www.tech9.net/rml/linux/
+# (preemptible kernel)
+# loopback device deadlock fixes from akpm
# UPDATED in 2.4.17-r4:
-# xfs was updated from 26 Jan 2002 to 13 Feb 2002 CVS
-# ide updated from 01192002 to 02072002
-# preempt was updated from -1 to -3
+# xfs was updated from 26 Jan 2002 to 13 Feb 2002 CVS
+# ide updated from 01192002 to 02072002
+# preempt was updated from -1 to -3
# REMOVED from 2.4.17-r4:
-# irqrate-a1 (which should close bug #396, possibly others)
-# acpi-20020208-2.4.17.diff.gz from http://sourceforge.net/projects/acpi
+# irqrate-a1 (which should close bug #396, possibly others)
+# acpi-20020208-2.4.17.diff.gz from http://sourceforge.net/projects/acpi
# (see bug #689; this patch conflicts with the stock aic7xxx scsi driver.
-# this bug has been sent upstream)
+# this bug has been sent upstream)
# Note: enable "Taskfile" options in kernel config if you're using IDE
# The linuxdiskcert site says "no" but the patch author says "yes"
DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
PROVIDE="virtual/kernel"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
@@ -77,11 +77,11 @@ src_unpack() {
#sometimes we have icky kernel symbols; this seems to get rid of them
make mrproper || die
- #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
+ #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
cp ${S}/arch/i386/defconfig .config || die
yes "" | make oldconfig
echo "Ignore any errors from the yes command above."
-
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 *
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild
index 5ea486fb7e9a..91d10a52455a 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild,v 1.5 2002/07/17 00:48:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild,v 1.6 2002/08/10 03:17:05 seemant Exp $
-SLOT="0"
-LICENSE="GPL"
DESCRIPTION="Obsolete kernel package. Please choose another"
HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
SRC_URI=""
+
+SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="x86 ppc"
pkg_setup() {
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
index b77a5f721b4a..72e4af6b5b6e 100644
--- a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
+++ b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.7 2002/07/16 04:49:51 gerk Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.8 2002/08/10 03:17:05 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files