summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild4
-rw-r--r--dev-python/sphinx/sphinx-0.6.3.ebuild14
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild b/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
index 8157e6434df4..3e316a3f2b7d 100644
--- a/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
+++ b/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild,v 1.5 2010/02/26 04:47:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.3.ebuild,v 1.6 2010/02/28 10:47:17 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -42,7 +42,7 @@ src_compile() {
distutils_src_compile
if use doc; then
export VARTEXFONTS="${T}/fonts"
- ${python} setup.py build_docs --formats=html,pdf \
+ "$(PYTHON -f)" setup.py build_docs --formats=html,pdf \
|| die "doc building failed"
fi
}
diff --git a/dev-python/sphinx/sphinx-0.6.3.ebuild b/dev-python/sphinx/sphinx-0.6.3.ebuild
index e506cbcaa639..0c8209dcb771 100644
--- a/dev-python/sphinx/sphinx-0.6.3.ebuild
+++ b/dev-python/sphinx/sphinx-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.3.ebuild,v 1.12 2009/12/20 12:27:24 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.3.ebuild,v 1.13 2010/02/28 10:51:15 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -25,20 +25,18 @@ RDEPEND=">=dev-python/pygments-0.8
DEPEND="${RDEPEND}
dev-python/setuptools
test? ( dev-python/nose )"
-
-RESTRICT_PYTHON_ABIS="3*"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
+DOCS="CHANGES"
+
src_compile() {
- DOCS="CHANGES"
distutils_src_compile
if use doc; then
cd doc
- PYTHONPATH="../" emake \
- SPHINXBUILD="${python} ../sphinx-build.py" \
- html || die "making docs failed"
+ PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
fi
}
@@ -53,7 +51,7 @@ src_install() {
distutils_src_install
if use doc; then
- dohtml -A txt -r doc/_build/html/* || die
+ dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
fi
}