summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090402.ebuild55
-rw-r--r--app-i18n/ibus-table-erbi/ChangeLog8
-rw-r--r--app-i18n/ibus-table-erbi/ibus-table-erbi-1.1.0.20090402.ebuild36
-rw-r--r--app-i18n/ibus-table-extraphrase/ChangeLog8
-rw-r--r--app-i18n/ibus-table-extraphrase/ibus-table-extraphrase-1.1.0.20090327.ebuild22
-rw-r--r--app-i18n/ibus-table-zhengma/ChangeLog8
-rw-r--r--app-i18n/ibus-table-zhengma/ibus-table-zhengma-1.1.0.20090402.ebuild36
8 files changed, 177 insertions, 4 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 7365f3498c3f..976081ae4958 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.7 2009/03/31 14:56:39 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.8 2009/04/02 16:04:05 matsuu Exp $
+
+*ibus-anthy-1.1.0.20090402 (02 Apr 2009)
+
+ 02 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.1.0.20090402.ebuild:
+ Version bumped.
31 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-anthy-0.1.1.20090203.ebuild, -ibus-anthy-1.1.0.20090205.ebuild:
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090402.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090402.ebuild
new file mode 100644
index 000000000000..d37e661f4a48
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090402.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090402.ebuild,v 1.1 2009/04/02 16:04:05 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-table-erbi/ChangeLog b/app-i18n/ibus-table-erbi/ChangeLog
index b0b6368796eb..a7cc2db78aee 100644
--- a/app-i18n/ibus-table-erbi/ChangeLog
+++ b/app-i18n/ibus-table-erbi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table-erbi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-erbi/ChangeLog,v 1.4 2009/03/31 14:59:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-erbi/ChangeLog,v 1.5 2009/04/02 16:00:27 matsuu Exp $
+
+*ibus-table-erbi-1.1.0.20090402 (02 Apr 2009)
+
+ 02 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-erbi-1.1.0.20090402.ebuild:
+ Version bumped.
31 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-table-erbi-0.1.2.20090101.ebuild:
diff --git a/app-i18n/ibus-table-erbi/ibus-table-erbi-1.1.0.20090402.ebuild b/app-i18n/ibus-table-erbi/ibus-table-erbi-1.1.0.20090402.ebuild
new file mode 100644
index 000000000000..0b1438069754
--- /dev/null
+++ b/app-i18n/ibus-table-erbi/ibus-table-erbi-1.1.0.20090402.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-erbi/ibus-table-erbi-1.1.0.20090402.ebuild,v 1.1 2009/04/02 16:00:27 matsuu Exp $
+
+DESCRIPTION="The ErBi for IBus Tables"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-phrases"
+
+RDEPEND=">=app-i18n/ibus-table-1.1"
+DEPEND="${RDEPEND}
+ extra-phrases? ( >=app-i18n/ibus-table-extraphrase-1.1 )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable extra-phrases) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}
diff --git a/app-i18n/ibus-table-extraphrase/ChangeLog b/app-i18n/ibus-table-extraphrase/ChangeLog
index 270aa7dff20f..952e6bb60112 100644
--- a/app-i18n/ibus-table-extraphrase/ChangeLog
+++ b/app-i18n/ibus-table-extraphrase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table-extraphrase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-extraphrase/ChangeLog,v 1.4 2009/03/31 15:12:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-extraphrase/ChangeLog,v 1.5 2009/04/02 16:00:19 matsuu Exp $
+
+*ibus-table-extraphrase-1.1.0.20090327 (02 Apr 2009)
+
+ 02 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-extraphrase-1.1.0.20090327.ebuild:
+ Version bumped.
31 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-table-extraphrase-0.1.2.20090102.ebuild:
diff --git a/app-i18n/ibus-table-extraphrase/ibus-table-extraphrase-1.1.0.20090327.ebuild b/app-i18n/ibus-table-extraphrase/ibus-table-extraphrase-1.1.0.20090327.ebuild
new file mode 100644
index 000000000000..4348aa568f41
--- /dev/null
+++ b/app-i18n/ibus-table-extraphrase/ibus-table-extraphrase-1.1.0.20090327.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-extraphrase/ibus-table-extraphrase-1.1.0.20090327.ebuild,v 1.1 2009/04/02 16:00:19 matsuu Exp $
+
+DESCRIPTION="Chinese extra phrases for ibus-table based IME"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-i18n/ibus-table-1.1
+ dev-util/pkgconfig"
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/app-i18n/ibus-table-zhengma/ChangeLog b/app-i18n/ibus-table-zhengma/ChangeLog
index ecdaf71a233c..5548a00cea26 100644
--- a/app-i18n/ibus-table-zhengma/ChangeLog
+++ b/app-i18n/ibus-table-zhengma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table-zhengma
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-zhengma/ChangeLog,v 1.4 2009/03/31 15:00:18 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-zhengma/ChangeLog,v 1.5 2009/04/02 16:03:59 matsuu Exp $
+
+*ibus-table-zhengma-1.1.0.20090402 (02 Apr 2009)
+
+ 02 Apr 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-zhengma-1.1.0.20090402.ebuild:
+ Version bumped.
31 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-table-zhengma-0.1.2.20090101.ebuild:
diff --git a/app-i18n/ibus-table-zhengma/ibus-table-zhengma-1.1.0.20090402.ebuild b/app-i18n/ibus-table-zhengma/ibus-table-zhengma-1.1.0.20090402.ebuild
new file mode 100644
index 000000000000..83d244e4d36b
--- /dev/null
+++ b/app-i18n/ibus-table-zhengma/ibus-table-zhengma-1.1.0.20090402.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table-zhengma/ibus-table-zhengma-1.1.0.20090402.ebuild,v 1.1 2009/04/02 16:03:59 matsuu Exp $
+
+DESCRIPTION="The ZhengMa for IBus Tables"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-phrases"
+
+RDEPEND=">=app-i18n/ibus-table-1.1"
+DEPEND="${RDEPEND}
+ extra-phrases? ( >=app-i18n/ibus-table-extraphrase-1.1 )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable extra-phrases) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}