summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt-core/ChangeLog6
-rw-r--r--x11-libs/qt-core/files/blacklist_ssl.patch89
-rw-r--r--x11-libs/qt-core/files/qt-4.6-nolibx11.patch18
-rw-r--r--x11-libs/qt-core/files/qt-4.6-nox11r6.patch152
-rw-r--r--x11-libs/qt-dbus/ChangeLog5
-rw-r--r--x11-libs/qt-dbus/files/qt-4.6-nolibx11.patch18
-rw-r--r--x11-libs/qt-gui/ChangeLog6
-rw-r--r--x11-libs/qt-gui/files/qt-gui-4.6-libpng-1.5.patch283
-rw-r--r--x11-libs/qt-script/ChangeLog5
-rw-r--r--x11-libs/qt-script/files/qt-4.6-nolibx11.patch18
-rw-r--r--x11-libs/qt-sql/ChangeLog5
-rw-r--r--x11-libs/qt-sql/files/qt-4.6-nolibx11.patch18
12 files changed, 22 insertions, 601 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index e6c58f93fddb..2a8790023b19 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.183 2012/07/09 11:34:24 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.184 2012/07/09 12:15:03 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org> -files/blacklist_ssl.patch,
+ -files/qt-4.6-nolibx11.patch, -files/qt-4.6-nox11r6.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-core-4.6.3-r1.ebuild:
Drop Qt-4.6.3
diff --git a/x11-libs/qt-core/files/blacklist_ssl.patch b/x11-libs/qt-core/files/blacklist_ssl.patch
deleted file mode 100644
index abefeff8fc69..000000000000
--- a/x11-libs/qt-core/files/blacklist_ssl.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-diff --git a/src/network/ssl/qsslcertificate.cpp b/src/network/ssl/qsslcertificate.cpp
-index 618ac79..a5cdf01 100644
---- a/src/network/ssl/qsslcertificate.cpp
-+++ b/src/network/ssl/qsslcertificate.cpp
-@@ -219,17 +219,19 @@ bool QSslCertificate::isNull() const
- Returns true if this certificate is valid; otherwise returns
- false.
-
-- Note: Currently, this function only checks that the current
-+ Note: Currently, this function checks that the current
- data-time is within the date-time range during which the
-- certificate is considered valid. No other checks are
-- currently performed.
-+ certificate is considered valid, and checks that the
-+ certificate is not in a blacklist of fraudulent certificates.
-
- \sa isNull()
- */
- bool QSslCertificate::isValid() const
- {
- const QDateTime currentTime = QDateTime::currentDateTime();
-- return currentTime >= d->notValidBefore && currentTime <= d->notValidAfter;
-+ return currentTime >= d->notValidBefore &&
-+ currentTime <= d->notValidAfter &&
-+ ! QSslCertificatePrivate::isBlacklisted(*this);
- }
-
- /*!
-@@ -798,6 +800,30 @@ QList<QSslCertificate> QSslCertificatePrivate::certificatesFromDer(const QByteAr
- return certificates;
- }
-
-+// These certificates are known to be fraudulent and were created during the comodo
-+// compromise. See http://www.comodo.com/Comodo-Fraud-Incident-2011-03-23.html
-+static const char *certificate_blacklist[] = {
-+ "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e",
-+ "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06",
-+ "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3",
-+ "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29",
-+ "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71",
-+ "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47",
-+ "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43",
-+ "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0",
-+ "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0",
-+ 0
-+};
-+
-+bool QSslCertificatePrivate::isBlacklisted(const QSslCertificate &certificate)
-+{
-+ for (int a = 0; certificate_blacklist[a] != 0; a++) {
-+ if (certificate.serialNumber() == certificate_blacklist[a])
-+ return true;
-+ }
-+ return false;
-+}
-+
- #ifndef QT_NO_DEBUG_STREAM
- QDebug operator<<(QDebug debug, const QSslCertificate &certificate)
- {
-diff --git a/src/network/ssl/qsslcertificate_p.h b/src/network/ssl/qsslcertificate_p.h
-index cdceb0f..1ce33d3 100644
---- a/src/network/ssl/qsslcertificate_p.h
-+++ b/src/network/ssl/qsslcertificate_p.h
-@@ -96,6 +96,7 @@ public:
- static QSslCertificate QSslCertificate_from_X509(X509 *x509);
- static QList<QSslCertificate> certificatesFromPem(const QByteArray &pem, int count = -1);
- static QList<QSslCertificate> certificatesFromDer(const QByteArray &der, int count = -1);
-+ static bool isBlacklisted(const QSslCertificate &certificate);
-
- friend class QSslSocketBackendPrivate;
-
-diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
-index 0866534..2427193 100644
---- a/src/network/ssl/qsslsocket_openssl.cpp
-+++ b/src/network/ssl/qsslsocket_openssl.cpp
-@@ -1193,6 +1193,13 @@ bool QSslSocketBackendPrivate::startHandshake()
- X509 *x509 = q_SSL_get_peer_certificate(ssl);
- configuration.peerCertificate = QSslCertificatePrivate::QSslCertificate_from_X509(x509);
- q_X509_free(x509);
-+ if (QSslCertificatePrivate::isBlacklisted(configuration.peerCertificate)) {
-+ q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
-+ q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
-+ emit q->error(QAbstractSocket::SslHandshakeFailedError);
-+ plainSocket->disconnectFromHost();
-+ return false;
-+ }
-
- // Start translating errors.
- QList<QSslError> errors;
diff --git a/x11-libs/qt-core/files/qt-4.6-nolibx11.patch b/x11-libs/qt-core/files/qt-4.6-nolibx11.patch
deleted file mode 100644
index e5d13327b8ce..000000000000
--- a/x11-libs/qt-core/files/qt-4.6-nolibx11.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure-orig 2010-01-20 14:18:32.466798257 +0200
-+++ configure 2010-01-20 14:18:58.516799116 +0200
-@@ -5059,15 +5059,6 @@
- X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
- fi
-
-- # Check we actually have X11 :-)
-- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
-- if [ $? != "0" ]; then
-- echo "Basic XLib functionality test failed!"
-- echo " You might need to modify the include and library search paths by editing"
-- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
-- exit 1
-- fi
--
- # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
- if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
- if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-core/files/qt-4.6-nox11r6.patch b/x11-libs/qt-core/files/qt-4.6-nox11r6.patch
deleted file mode 100644
index ec5ef92fa441..000000000000
--- a/x11-libs/qt-core/files/qt-4.6-nox11r6.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-diff --git a/mkspecs/common/linux.conf b/mkspecs/common/linux.conf
-index 1ae5608..9c603a6 100644
---- a/mkspecs/common/linux.conf
-+++ b/mkspecs/common/linux.conf
-@@ -7,12 +7,12 @@ QMAKE_CXXFLAGS_THREAD += $$QMAKE_CFLAGS_THREAD
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
- QMAKE_INCDIR_OPENGL_ES1 = $$QMAKE_INCDIR_OPENGL
- QMAKE_LIBDIR_OPENGL_ES1 = $$QMAKE_LIBDIR_OPENGL
- QMAKE_INCDIR_OPENGL_ES1CL = $$QMAKE_INCDIR_OPENGL
-diff --git a/mkspecs/linux-cxx/qmake.conf b/mkspecs/linux-cxx/qmake.conf
-index 633b738..a37c05b 100644
---- a/mkspecs/linux-cxx/qmake.conf
-+++ b/mkspecs/linux-cxx/qmake.conf
-@@ -37,12 +37,12 @@ QMAKE_CXXFLAGS_YACC = $$QMAKE_CFLAGS_YACC
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
-
- QMAKE_LINK = cxx
- QMAKE_LINK_SHLIB = cxx
-diff --git a/mkspecs/linux-ecc-64/qmake.conf b/mkspecs/linux-ecc-64/qmake.conf
-index 359d44b..2d3f9a5 100644
---- a/mkspecs/linux-ecc-64/qmake.conf
-+++ b/mkspecs/linux-ecc-64/qmake.conf
-@@ -39,12 +39,12 @@ QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
-
- QMAKE_LINK = ecpc
- QMAKE_LINK_SHLIB = ecpc
-diff --git a/mkspecs/linux-g++-64/qmake.conf b/mkspecs/linux-g++-64/qmake.conf
-index 4f8794f..cf7be62 100644
---- a/mkspecs/linux-g++-64/qmake.conf
-+++ b/mkspecs/linux-g++-64/qmake.conf
-@@ -17,7 +17,7 @@ QMAKE_LFLAGS = -m64
- include(../common/g++.conf)
- include(../common/linux.conf)
-
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib64
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib64
-+QMAKE_LIBDIR_X11 = /usr/lib64
-+QMAKE_LIBDIR_OPENGL = /usr/lib64
-
- load(qt_config)
-diff --git a/mkspecs/linux-icc-64/qmake.conf b/mkspecs/linux-icc-64/qmake.conf
-index 7962026..9b4bade 100644
---- a/mkspecs/linux-icc-64/qmake.conf
-+++ b/mkspecs/linux-icc-64/qmake.conf
-@@ -12,5 +12,5 @@ include(../linux-icc/qmake.conf)
-
- # Change the all LIBDIR variables to use lib64 instead of lib
-
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib64
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib64
-+QMAKE_LIBDIR_X11 = /usr/lib64
-+QMAKE_LIBDIR_OPENGL = /usr/lib64
-diff --git a/mkspecs/linux-icc/qmake.conf b/mkspecs/linux-icc/qmake.conf
-index 965de0c..b778a89 100644
---- a/mkspecs/linux-icc/qmake.conf
-+++ b/mkspecs/linux-icc/qmake.conf
-@@ -45,12 +45,12 @@ QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
-
- QMAKE_LINK = icpc
- QMAKE_LINK_SHLIB = icpc
-diff --git a/mkspecs/linux-kcc/qmake.conf b/mkspecs/linux-kcc/qmake.conf
-index 009c486..0e3d301 100644
---- a/mkspecs/linux-kcc/qmake.conf
-+++ b/mkspecs/linux-kcc/qmake.conf
-@@ -48,12 +48,12 @@ QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
-
- QMAKE_LINK = KCC
- QMAKE_LINK_SHLIB = KCC
-diff --git a/mkspecs/linux-pgcc/qmake.conf b/mkspecs/linux-pgcc/qmake.conf
-index 756f1af..2c40635 100644
---- a/mkspecs/linux-pgcc/qmake.conf
-+++ b/mkspecs/linux-pgcc/qmake.conf
-@@ -39,12 +39,12 @@ QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
-
- QMAKE_INCDIR =
- QMAKE_LIBDIR =
--QMAKE_INCDIR_X11 = /usr/X11R6/include
--QMAKE_LIBDIR_X11 = /usr/X11R6/lib
-+QMAKE_INCDIR_X11 = /usr/include
-+QMAKE_LIBDIR_X11 = /usr/lib
- QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
- QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]
--QMAKE_INCDIR_OPENGL = /usr/X11R6/include
--QMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
-+QMAKE_INCDIR_OPENGL = /usr/include
-+QMAKE_LIBDIR_OPENGL = /usr/lib
-
- QMAKE_LINK = pgCC
- QMAKE_LINK_SHLIB = pgCC
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index 04bd36a5313c..07438160cf9f 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.123 2012/07/09 11:35:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.124 2012/07/09 12:16:37 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org> -files/qt-4.6-nolibx11.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-dbus-4.6.3.ebuild:
Drop Qt-4.6.3
diff --git a/x11-libs/qt-dbus/files/qt-4.6-nolibx11.patch b/x11-libs/qt-dbus/files/qt-4.6-nolibx11.patch
deleted file mode 100644
index e5d13327b8ce..000000000000
--- a/x11-libs/qt-dbus/files/qt-4.6-nolibx11.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure-orig 2010-01-20 14:18:32.466798257 +0200
-+++ configure 2010-01-20 14:18:58.516799116 +0200
-@@ -5059,15 +5059,6 @@
- X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
- fi
-
-- # Check we actually have X11 :-)
-- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
-- if [ $? != "0" ]; then
-- echo "Basic XLib functionality test failed!"
-- echo " You might need to modify the include and library search paths by editing"
-- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
-- exit 1
-- fi
--
- # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
- if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
- if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-gui/ChangeLog b/x11-libs/qt-gui/ChangeLog
index f61a6c3a6392..997a8c7bc599 100644
--- a/x11-libs/qt-gui/ChangeLog
+++ b/x11-libs/qt-gui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-gui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.193 2012/07/09 11:36:35 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.194 2012/07/09 12:20:40 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org>
+ -files/qt-gui-4.6-libpng-1.5.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-gui-4.6.3.ebuild,
-qt-gui-4.6.3-r2.ebuild:
diff --git a/x11-libs/qt-gui/files/qt-gui-4.6-libpng-1.5.patch b/x11-libs/qt-gui/files/qt-gui-4.6-libpng-1.5.patch
deleted file mode 100644
index 8c7f2fa908ed..000000000000
--- a/x11-libs/qt-gui/files/qt-gui-4.6-libpng-1.5.patch
+++ /dev/null
@@ -1,283 +0,0 @@
-From 8a81562af30435f82255830489dca691031a5408 Mon Sep 17 00:00:00 2001
-From: aavit <qt-info@nokia.com>
-Date: Tue, 9 Feb 2010 10:32:04 +0100
-Subject: [PATCH] Use libpng API as recommended. Preparation for upgrade to libpng 1.4.0.
-
-The libpng doc advises against accessing the info_ptr structure
-directly, and in 1.4.0 the members are flagged as deprecated, so such
-access gives compilation warnings. This patch makes qpnghandler use
-the recommended access functions instead.
-
-Reviewed-by: Trond
----
- src/gui/image/qpnghandler.cpp | 135 +++++++++++++++++++----------------------
- 1 files changed, 62 insertions(+), 73 deletions(-)
-
-diff --git a/src/gui/image/qpnghandler.cpp b/src/gui/image/qpnghandler.cpp
-index d5406cb..bba54b9 100644
---- a/src/gui/image/qpnghandler.cpp
-+++ b/src/gui/image/qpnghandler.cpp
-@@ -50,8 +50,13 @@
- #include <qvariant.h>
- #include <qvector.h>
-
-+#ifdef QT_USE_BUNDLED_LIBPNG
-+#include <../../3rdparty/libpng/png.h>
-+#include <../../3rdparty/libpng/pngconf.h>
-+#else
- #include <png.h>
- #include <pngconf.h>
-+#endif
-
- #ifdef Q_OS_WINCE
- #define CALLBACK_CALL_TYPE __cdecl
-@@ -162,11 +167,16 @@ void setup_qt(QImage& image, png_structp png_ptr, png_infop info_ptr, float scre
- png_uint_32 height;
- int bit_depth;
- int color_type;
-+ png_bytep trans_alpha = 0;
-+ png_color_16p trans_color_p = 0;
-+ int num_trans;
-+ png_colorp palette = 0;
-+ int num_palette;
- png_get_IHDR(png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, 0, 0, 0);
-
- if (color_type == PNG_COLOR_TYPE_GRAY) {
- // Black & White or 8-bit grayscale
-- if (bit_depth == 1 && info_ptr->channels == 1) {
-+ if (bit_depth == 1 && png_get_channels(png_ptr, info_ptr) == 1) {
- png_set_invert_mono(png_ptr);
- png_read_update_info(png_ptr, info_ptr);
- if (image.size() != QSize(width, height) || image.format() != QImage::Format_Mono) {
-@@ -207,20 +217,16 @@ void setup_qt(QImage& image, png_structp png_ptr, png_infop info_ptr, float scre
- int c = i*255/(ncols-1);
- image.setColor(i, qRgba(c,c,c,0xff));
- }
-- if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
--#if PNG_LIBPNG_VER_MAJOR < 1 || (PNG_LIBPNG_VER_MAJOR == 1 && PNG_LIBPNG_VER_MINOR < 4)
-- const int g = info_ptr->trans_values.gray;
--#else
-- const int g = info_ptr->trans_color.gray;
--#endif
-+ if (png_get_tRNS(png_ptr, info_ptr, &trans_alpha, &num_trans, &trans_color_p) && trans_color_p) {
-+ const int g = trans_color_p->gray;
- if (g < ncols) {
- image.setColor(g, 0);
- }
- }
- }
- } else if (color_type == PNG_COLOR_TYPE_PALETTE
-- && png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)
-- && info_ptr->num_palette <= 256)
-+ && png_get_PLTE(png_ptr, info_ptr, &palette, &num_palette)
-+ && num_palette <= 256)
- {
- // 1-bit and 8-bit color
- if (bit_depth != 1)
-@@ -233,29 +239,26 @@ void setup_qt(QImage& image, png_structp png_ptr, png_infop info_ptr, float scre
- if (image.isNull())
- return;
- }
-- image.setColorCount(info_ptr->num_palette);
-+ png_get_PLTE(png_ptr, info_ptr, &palette, &num_palette);
-+ image.setColorCount(num_palette);
- int i = 0;
-- if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
-- while (i < info_ptr->num_trans) {
-+ if (png_get_tRNS(png_ptr, info_ptr, &trans_alpha, &num_trans, &trans_color_p) && trans_alpha) {
-+ while (i < num_trans) {
- image.setColor(i, qRgba(
-- info_ptr->palette[i].red,
-- info_ptr->palette[i].green,
-- info_ptr->palette[i].blue,
--#if PNG_LIBPNG_VER_MAJOR < 1 || (PNG_LIBPNG_VER_MAJOR == 1 && PNG_LIBPNG_VER_MINOR < 4)
-- info_ptr->trans[i]
--#else
-- info_ptr->trans_alpha[i]
--#endif
-+ palette[i].red,
-+ palette[i].green,
-+ palette[i].blue,
-+ trans_alpha[i]
- )
- );
- i++;
- }
- }
-- while (i < info_ptr->num_palette) {
-+ while (i < num_palette) {
- image.setColor(i, qRgba(
-- info_ptr->palette[i].red,
-- info_ptr->palette[i].green,
-- info_ptr->palette[i].blue,
-+ palette[i].red,
-+ palette[i].green,
-+ palette[i].blue,
- 0xff
- )
- );
-@@ -531,33 +534,36 @@ QImage::Format QPngHandlerPrivate::readImageFormat()
- QImage::Format format = QImage::Format_Invalid;
- png_uint_32 width, height;
- int bit_depth, color_type;
-- if (info_ptr->color_type == PNG_COLOR_TYPE_GRAY) {
-+ png_colorp palette;
-+ int num_palette;
-+ png_get_IHDR(png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, 0, 0, 0);
-+ if (color_type == PNG_COLOR_TYPE_GRAY) {
- // Black & White or 8-bit grayscale
-- if (info_ptr->bit_depth == 1 && info_ptr->channels == 1) {
-+ if (bit_depth == 1 && png_get_channels(png_ptr, info_ptr) == 1) {
- format = QImage::Format_Mono;
-- } else if (info_ptr->bit_depth == 16 && png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
-+ } else if (bit_depth == 16 && png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
- format = QImage::Format_ARGB32;
- } else {
- format = QImage::Format_Indexed8;
- }
-- } else if (info_ptr->color_type == PNG_COLOR_TYPE_PALETTE
-- && png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)
-- && info_ptr->num_palette <= 256)
-+ } else if (color_type == PNG_COLOR_TYPE_PALETTE
-+ && png_get_PLTE(png_ptr, info_ptr, &palette, &num_palette)
-+ && num_palette <= 256)
- {
- // 1-bit and 8-bit color
-- if (info_ptr->bit_depth != 1)
-+ if (bit_depth != 1)
- png_set_packing(png_ptr);
- png_read_update_info(png_ptr, info_ptr);
- png_get_IHDR(png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, 0, 0, 0);
- format = bit_depth == 1 ? QImage::Format_Mono : QImage::Format_Indexed8;
- } else {
- // 32-bit
-- if (info_ptr->bit_depth == 16)
-+ if (bit_depth == 16)
- png_set_strip_16(png_ptr);
-
- format = QImage::Format_ARGB32;
- // Only add filler if no alpha, or we can get 5 channel data.
-- if (!(info_ptr->color_type & PNG_COLOR_MASK_ALPHA)
-+ if (!(color_type & PNG_COLOR_MASK_ALPHA)
- && !png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
- // We want 4 bytes, but it isn't an alpha channel
- format = QImage::Format_RGB32;
-@@ -648,7 +654,7 @@ static void set_text(const QImage &image, png_structp png_ptr, png_infop info_pt
- text_ptr[i].text = qstrdup(value.constData());
- text_ptr[i].text_length = 0;
- text_ptr[i].itxt_length = value.size();
-- text_ptr[i].lang = "UTF-8";
-+ text_ptr[i].lang = const_cast<char*>("UTF-8");
- text_ptr[i].lang_key = qstrdup(it.key().toUtf8().constData());
- #endif
- ++i;
-@@ -735,64 +741,51 @@ bool Q_INTERNAL_WIN_NO_THROW QPNGImageWriter::writeImage(const QImage& image_in,
- png_set_compression_level(png_ptr, quality);
- }
-
-- if (gamma != 0.0) {
-- png_set_gAMA(png_ptr, info_ptr, 1.0/gamma);
-- }
--
- png_set_write_fn(png_ptr, (void*)this, qpiw_write_fn, qpiw_flush_fn);
-
-- info_ptr->channels =
-- (image.depth() == 32)
-- ? (image.format() == QImage::Format_RGB32 ? 3 : 4)
-- : 1;
--
- png_set_IHDR(png_ptr, info_ptr, image.width(), image.height(),
- image.depth() == 1 ? 1 : 8 /* per channel */,
- image.depth() == 32
- ? image.format() == QImage::Format_RGB32
- ? PNG_COLOR_TYPE_RGB
- : PNG_COLOR_TYPE_RGB_ALPHA
-- : PNG_COLOR_TYPE_PALETTE, 0, 0, 0);
-+ : PNG_COLOR_TYPE_PALETTE, 0, 0, 0); // also sets #channels
-
-+ if (gamma != 0.0) {
-+ png_set_gAMA(png_ptr, info_ptr, 1.0/gamma);
-+ }
-
-- //png_set_sBIT(png_ptr, info_ptr, 8);
-- info_ptr->sig_bit.red = 8;
-- info_ptr->sig_bit.green = 8;
-- info_ptr->sig_bit.blue = 8;
-+ png_color_8 sig_bit;
-+ sig_bit.red = 8;
-+ sig_bit.green = 8;
-+ sig_bit.blue = 8;
-+ sig_bit.alpha = image.hasAlphaChannel() ? 8 : 0;
-+ png_set_sBIT(png_ptr, info_ptr, &sig_bit);
-
- if (image.format() == QImage::Format_MonoLSB)
- png_set_packswap(png_ptr);
-
-- png_colorp palette = 0;
-- png_bytep copy_trans = 0;
- if (image.colorCount()) {
- // Paletted
- int num_palette = image.colorCount();
-- palette = new png_color[num_palette];
-- png_set_PLTE(png_ptr, info_ptr, palette, num_palette);
-- int* trans = new int[num_palette];
-+ png_color palette[num_palette];
-+ png_byte trans[num_palette];
- int num_trans = 0;
- for (int i=0; i<num_palette; i++) {
-- QRgb rgb=image.color(i);
-- info_ptr->palette[i].red = qRed(rgb);
-- info_ptr->palette[i].green = qGreen(rgb);
-- info_ptr->palette[i].blue = qBlue(rgb);
-- trans[i] = rgb >> 24;
-+ QRgb rgba=image.color(i);
-+ palette[i].red = qRed(rgba);
-+ palette[i].green = qGreen(rgba);
-+ palette[i].blue = qBlue(rgba);
-+ trans[i] = qAlpha(rgba);
- if (trans[i] < 255) {
- num_trans = i+1;
- }
- }
-+ png_set_PLTE(png_ptr, info_ptr, palette, num_palette);
-+
- if (num_trans) {
-- copy_trans = new png_byte[num_trans];
-- for (int i=0; i<num_trans; i++)
-- copy_trans[i] = trans[i];
-- png_set_tRNS(png_ptr, info_ptr, copy_trans, num_trans, 0);
-+ png_set_tRNS(png_ptr, info_ptr, trans, num_trans, 0);
- }
-- delete [] trans;
-- }
--
-- if (image.format() != QImage::Format_RGB32) {
-- info_ptr->sig_bit.alpha = 8;
- }
-
- // Swap ARGB to RGBA (normal PNG format) before saving on
-@@ -868,11 +861,6 @@ bool Q_INTERNAL_WIN_NO_THROW QPNGImageWriter::writeImage(const QImage& image_in,
- png_write_end(png_ptr, info_ptr);
- frames_written++;
-
-- if (palette)
-- delete [] palette;
-- if (copy_trans)
-- delete [] copy_trans;
--
- png_destroy_write_struct(&png_ptr, &info_ptr);
-
- return true;
-@@ -958,7 +946,8 @@ QVariant QPngHandler::option(ImageOption option) const
- else if (option == Description)
- return d->description;
- else if (option == Size)
-- return QSize(d->info_ptr->width, d->info_ptr->height);
-+ return QSize(png_get_image_width(d->png_ptr, d->info_ptr),
-+ png_get_image_height(d->png_ptr, d->info_ptr));
- else if (option == ImageFormat)
- return d->readImageFormat();
- return 0;
---
-1.6.1
-
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 1058277d6e3a..6013d9f9c738 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.127 2012/07/09 11:39:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.128 2012/07/09 12:24:09 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org> -files/qt-4.6-nolibx11.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-script-4.6.3.ebuild:
Drop Qt-4.6.3
diff --git a/x11-libs/qt-script/files/qt-4.6-nolibx11.patch b/x11-libs/qt-script/files/qt-4.6-nolibx11.patch
deleted file mode 100644
index e5d13327b8ce..000000000000
--- a/x11-libs/qt-script/files/qt-4.6-nolibx11.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure-orig 2010-01-20 14:18:32.466798257 +0200
-+++ configure 2010-01-20 14:18:58.516799116 +0200
-@@ -5059,15 +5059,6 @@
- X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
- fi
-
-- # Check we actually have X11 :-)
-- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
-- if [ $? != "0" ]; then
-- echo "Basic XLib functionality test failed!"
-- echo " You might need to modify the include and library search paths by editing"
-- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
-- exit 1
-- fi
--
- # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
- if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
- if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 6eb0b2ba1e9c..226c028faa9b 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.145 2012/07/09 11:40:43 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.146 2012/07/09 12:25:37 johu Exp $
+
+ 09 Jul 2012; Johannes Huber <johu@gentoo.org> -files/qt-4.6-nolibx11.patch:
+ Remove old.
09 Jul 2012; Johannes Huber <johu@gentoo.org> -qt-sql-4.6.3-r2.ebuild:
Drop Qt-4.6.3
diff --git a/x11-libs/qt-sql/files/qt-4.6-nolibx11.patch b/x11-libs/qt-sql/files/qt-4.6-nolibx11.patch
deleted file mode 100644
index e5d13327b8ce..000000000000
--- a/x11-libs/qt-sql/files/qt-4.6-nolibx11.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure-orig 2010-01-20 14:18:32.466798257 +0200
-+++ configure 2010-01-20 14:18:58.516799116 +0200
-@@ -5059,15 +5059,6 @@
- X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
- fi
-
-- # Check we actually have X11 :-)
-- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
-- if [ $? != "0" ]; then
-- echo "Basic XLib functionality test failed!"
-- echo " You might need to modify the include and library search paths by editing"
-- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
-- exit 1
-- fi
--
- # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
- if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
- if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then