summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/upnp/ChangeLog7
-rw-r--r--net-misc/upnp/Manifest16
-rw-r--r--net-misc/upnp/files/digest-upnp-1.2.1a1
-rw-r--r--net-misc/upnp/upnp-1.2.1a.ebuild60
4 files changed, 81 insertions, 3 deletions
diff --git a/net-misc/upnp/ChangeLog b/net-misc/upnp/ChangeLog
index de933c6e6f44..8036ca55a188 100644
--- a/net-misc/upnp/ChangeLog
+++ b/net-misc/upnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/upnp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/ChangeLog,v 1.10 2005/04/24 02:47:41 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/ChangeLog,v 1.11 2005/06/07 08:54:02 dragonheart Exp $
+
+*upnp-1.2.1a (25 May 2005)
+
+ 25 May 2005; Daniel Black <dragonheart@gentoo.org> +upnp-1.2.1a.ebuild:
+ Version bump as per bug #59728 thanks to Brian Litzinger
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> upnp-1.0.4-r1.ebuild:
Stable on ppc.
diff --git a/net-misc/upnp/Manifest b/net-misc/upnp/Manifest
index 42fc012a90d4..31e76822c43e 100644
--- a/net-misc/upnp/Manifest
+++ b/net-misc/upnp/Manifest
@@ -1,6 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 9f6356c5c3c4c690d0601457a50f7862 ChangeLog 1198
MD5 1ab317d5868a9b63279d0fd1a2013ff7 upnp-1.0.4-r1.ebuild 919
-MD5 eda2b4499208de60145b16338448cb89 ChangeLog 1031
MD5 a0c64a5cb4d40e2ffa38d1a21c8d5915 upnp-1.0.4.ebuild 859
-MD5 9c84a2a05767ba2a9032b767c32b19d9 files/digest-upnp-1.0.4-r1 65
+MD5 450e19cb0d8ba30e5bd249efcdbced85 upnp-1.2.1a.ebuild 1270
MD5 9c84a2a05767ba2a9032b767c32b19d9 files/digest-upnp-1.0.4 65
+MD5 9c84a2a05767ba2a9032b767c32b19d9 files/digest-upnp-1.0.4-r1 65
MD5 d1e8a04f3971c238d992f69d683fe65b files/msmessenger.patch 590
+MD5 3dbbca36405d3fb80da9e680a2457e1e files/digest-upnp-1.2.1a 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCpWC/mdTrptrqvGERAqC+AJ0auzfo+FoL+E3oFuPurINkS7ZECACZAd/q
+bp5ffYUiGi//Y3QU/k6Lnqs=
+=zYoi
+-----END PGP SIGNATURE-----
diff --git a/net-misc/upnp/files/digest-upnp-1.2.1a b/net-misc/upnp/files/digest-upnp-1.2.1a
new file mode 100644
index 000000000000..d49a9db1c296
--- /dev/null
+++ b/net-misc/upnp/files/digest-upnp-1.2.1a
@@ -0,0 +1 @@
+MD5 e72b3550bf064eedf080f16f09688891 libupnp-1.2.1a.tar.gz 411423
diff --git a/net-misc/upnp/upnp-1.2.1a.ebuild b/net-misc/upnp/upnp-1.2.1a.ebuild
new file mode 100644
index 000000000000..db8a08957dcd
--- /dev/null
+++ b/net-misc/upnp/upnp-1.2.1a.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/upnp/upnp-1.2.1a.ebuild,v 1.1 2005/06/07 08:54:02 dragonheart Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${PN}sdk-${PV}"
+
+DESCRIPTION="Intel's UPnP SDK"
+HOMEPAGE="http://upnp.sourceforge.net"
+SRC_URI="mirror://sourceforge/upnp/lib${PN}-${PV}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc debug"
+
+DEPEND="sys-fs/e2fsprogs
+ doc? ( app-doc/doc++
+ app-text/tetex
+ app-text/ghostscript )"
+
+S=${WORKDIR}/lib${PN}-${PV}/upnp
+
+src_compile() {
+ myconf=""
+
+ if use debug; then
+ myconf="DEBUG=1"
+ fi
+
+ cd ${S} &&
+ emake ${myconf} || die "Compile failed!"
+
+ if use doc; then
+ emake doc || die "Documentation generation failed!"
+ fi
+}
+
+src_install () {
+ if use debug; then
+ dolib.so bin/debug/libupnp.so
+ dolib.so bin/debug/libixml.so
+ dolib.so bin/debug/libthreadutil_dbg.so
+ else
+ dolib.so bin/libupnp.so
+ dolib.so bin/libixml.so
+ dolib.so bin/libthreadutil.so
+ fi
+
+ dodir /usr/include/upnp
+ insinto /usr/include/upnp
+ doins inc/*.h
+
+ dodoc LICENSE ../README doc/UPnP_Programming_Guide.pdf
+ if use doc; then
+ dodoc doc/ixml.pdf doc/upnpsdk.pdf
+ dohtml doc/html/*
+ fi
+}