summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/commons-collections/ChangeLog6
-rw-r--r--dev-java/commons-collections/commons-collections-3.2-r1.ebuild63
-rw-r--r--dev-java/commons-configuration/ChangeLog6
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.4.ebuild67
4 files changed, 10 insertions, 132 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index 4b88b2faf0e5..aa7b58683d7b 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-collections
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.55 2010/01/03 20:23:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.56 2010/03/20 13:05:16 betelgeuse Exp $
+
+ 20 Mar 2010; Petteri Räty <betelgeuse@gentoo.org>
+ -commons-collections-3.2-r1.ebuild:
+ Remove old version.
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
commons-collections-3.2.1.ebuild:
diff --git a/dev-java/commons-collections/commons-collections-3.2-r1.ebuild b/dev-java/commons-collections/commons-collections-3.2-r1.ebuild
deleted file mode 100644
index 360240800c2a..000000000000
--- a/dev-java/commons-collections/commons-collections-3.2-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-3.2-r1.ebuild,v 1.7 2008/06/23 09:43:33 ali_bush Exp $
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2 eutils
-
-DESCRIPTION="Jakarta-Commons Collections Component"
-HOMEPAGE="http://jakarta.apache.org/commons/collections/"
-SRC_URI="mirror://apache/${PN/-//}/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="test-framework"
-
-COMMON_DEP="test-framework? ( =dev-java/junit-3.8* )"
-DEPEND=">=virtual/jdk-1.4
- test? ( dev-java/ant-junit )
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-
-S="${WORKDIR}/${P}-src"
-
-src_unpack() {
- unpack ${A}
- rm -v "${S}"/*.jar || die
-}
-
-src_compile() {
- local antflags
- if use test-framework; then
- antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
- #no support for installing two sets of javadocs via dojavadoc atm
- #use doc && antflags="${antflags} tf.javadoc"
- fi
- eant jar $(use_doc) ${antflags}
-}
-
-src_test() {
- if [[ "${ARCH}" = "ppc" ]]; then
- einfo "Tests are disabled on ppc"
- else
- ANT_TASKS="ant-junit" eant testjar -Djunit.jar="$(java-pkg_getjars junit)"
- fi
-}
-
-src_install() {
- java-pkg_newjar build/${P}.jar ${PN}.jar
- use test-framework && \
- java-pkg_newjar build/${PN}-testframework-3.2.jar \
- ${PN}-testframework.jar
-
- dodoc README.txt || die
- java-pkg_dohtml *.html || die
- if use doc; then
- java-pkg_dojavadoc build/docs/apidocs
- #use test-framework && java-pkg_dojavadoc build/docs/testframework
- fi
- use source && java-pkg_dosrc src/java/*
-}
diff --git a/dev-java/commons-configuration/ChangeLog b/dev-java/commons-configuration/ChangeLog
index 99f18d694093..90cb5c22636a 100644
--- a/dev-java/commons-configuration/ChangeLog
+++ b/dev-java/commons-configuration/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-configuration
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-configuration/ChangeLog,v 1.10 2010/03/11 22:44:30 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-configuration/ChangeLog,v 1.11 2010/03/20 13:06:53 betelgeuse Exp $
+
+ 20 Mar 2010; Petteri Räty <betelgeuse@gentoo.org>
+ -commons-configuration-1.4.ebuild:
+ Remove old version.
11 Mar 2010; Sebastian Pipping <sping@gentoo.org>
commons-configuration-1.4.ebuild:
diff --git a/dev-java/commons-configuration/commons-configuration-1.4.ebuild b/dev-java/commons-configuration/commons-configuration-1.4.ebuild
deleted file mode 100644
index 842cec1512b4..000000000000
--- a/dev-java/commons-configuration/commons-configuration-1.4.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-configuration/commons-configuration-1.4.ebuild,v 1.5 2010/03/11 22:44:30 sping Exp $
-
-EAPI=1
-JAVA_PKG_IUSE="doc source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Java library for reading configuration data from a variety of sources."
-HOMEPAGE="http://commons.apache.org/configuration/"
-SRC_URI="http://archive.apache.org/dist/commons/configuration/source/${P}-src.tar.gz"
-
-COMMON_DEPENDS="
- >=dev-java/commons-beanutils-1.7.0:1.7
- >=dev-java/commons-codec-1.3:0
- >=dev-java/commons-collections-3.1:0
- >=dev-java/commons-digester-1.6:0
- >=dev-java/commons-jxpath-1.2:0
- >=dev-java/commons-lang-2.3:2.1
- >=dev-java/commons-logging-1.0.4:0
- >=dev-java/commons-httpclient-3.0:3
- dev-java/servletapi:2.4"
-
-DEPEND=">=virtual/jdk-1.4
- ${COMMON_DEPENDS}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPENDS}"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${P}-src"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Tweak build classpath and don't automatically run tests
- epatch "${FILESDIR}/${P}-gentoo.patch"
-
- java-ant_rewrite-classpath
-}
-
-EANT_GENTOO_CLASSPATH="
- commons-beanutils-1.7
- commons-codec
- commons-collections
- commons-digester
- commons-jxpath
- commons-lang-2.1
- commons-logging
- commons-httpclient-3
- servletapi-2.4"
-
-# Would need mockobjects with j2ee support which we don't have
-# Check overlay for ebuild with test support
-RESTRICT="test"
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
- dodoc RELEASE-NOTES.txt || die
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/*
-}