summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-02 11:52:21 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-02 11:52:21 +0000
commit63f7c93228f7ba463f012d2f48db086993a5bb2e (patch)
treebe7e58ff39aeabe56e33eed99028e66ed618aff6 /x11-wm
parentadded a lesspipe.sh script to the package. works real nice :) (diff)
downloadhistorical-63f7c93228f7ba463f012d2f48db086993a5bb2e.tar.gz
historical-63f7c93228f7ba463f012d2f48db086993a5bb2e.tar.bz2
historical-63f7c93228f7ba463f012d2f48db086993a5bb2e.zip
Updated to latesversion. I changed the location of the config files from
/etx/X11/xfce to /etc/xfce
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.111
-rw-r--r--x11-wm/xfce/xfce-3.8.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.11 b/x11-wm/xfce/files/digest-xfce-3.8.11
new file mode 100644
index 000000000000..33e1ea00ca12
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.11
@@ -0,0 +1 @@
+MD5 def34ac608e1c956f59cae6f1a75af6d xfce-3.8.11.tar.gz 3997696
diff --git a/x11-wm/xfce/xfce-3.8.11.ebuild b/x11-wm/xfce/xfce-3.8.11.ebuild
new file mode 100644
index 000000000000..01b946139f2e
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <ben@sistina.com>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.11.ebuild,v 1.1 2001/11/02 11:52:21 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="http://prdownloads.sourceforge.net/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+if [ -z "`use gnome`" ]
+then
+ DEPEND="${DEPEND} >=media-libs/imlib-1.9.10-r1"
+fi
+
+src_compile() {
+ local myconf
+
+ if [ "`use gnome`" ]
+ then
+ myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-data-dir=/usr/share/xfce \
+ --with-conf-dir=/etc/xfce \
+ --with-locale-dir=/usr/share/locale ${myconf}
+ try make
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+ dodir /etc/skel/.xfce
+}