summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-12 01:27:24 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-12 01:27:24 +0000
commitff4c8bb807657e91871d7b173e4d527c21a59448 (patch)
tree00ed4b4381ee7adaa1475094885d73c6b53a49c7 /x11-wm/metacity/metacity-2.16.3.ebuild
parentStable on alpha (diff)
downloadhistorical-ff4c8bb807657e91871d7b173e4d527c21a59448.tar.gz
historical-ff4c8bb807657e91871d7b173e4d527c21a59448.tar.bz2
historical-ff4c8bb807657e91871d7b173e4d527c21a59448.zip
Bump to 2.16.3
Package-Manager: portage-2.1.2_pre2-r8
Diffstat (limited to 'x11-wm/metacity/metacity-2.16.3.ebuild')
-rw-r--r--x11-wm/metacity/metacity-2.16.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.16.3.ebuild b/x11-wm/metacity/metacity-2.16.3.ebuild
new file mode 100644
index 000000000000..adaf622bf34f
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.16.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.16.3.ebuild,v 1.1 2006/10/12 01:27:24 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome default windowmanager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+# not parallel-safe; see bug #14405
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=x11-libs/pango-1.2
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ !x11-misc/expocity"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+pkg_setup() {
+ # Compositor is not deemed stable
+ G2CONF="$(use_enable xinerama) --disable-compositor"
+}