summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-12 01:04:39 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-12 01:04:39 +0000
commit06c67864dc268982e7b22aad8354edbd4b0f61e8 (patch)
tree4e3bf47dcbcd596cd99abf0401b9bff69bcaff6d /x11-wm/icewm
parentupdated to install in /usr, A=-fix (diff)
downloadhistorical-06c67864dc268982e7b22aad8354edbd4b0f61e8.tar.gz
historical-06c67864dc268982e7b22aad8354edbd4b0f61e8.tar.bz2
historical-06c67864dc268982e7b22aad8354edbd4b0f61e8.zip
updated to install in /usr and A=-fix
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.0.8.6-r1 (renamed from x11-wm/icewm/files/digest-icewm-1.0.8.6)0
-rwxr-xr-xx11-wm/icewm/files/icewm3
-rw-r--r--x11-wm/icewm/icewm-1.0.8.6-r1.ebuild34
-rw-r--r--x11-wm/icewm/icewm-1.0.8.6.ebuild30
4 files changed, 34 insertions, 33 deletions
diff --git a/x11-wm/icewm/files/digest-icewm-1.0.8.6 b/x11-wm/icewm/files/digest-icewm-1.0.8.6-r1
index b24c5af82d16..b24c5af82d16 100644
--- a/x11-wm/icewm/files/digest-icewm-1.0.8.6
+++ b/x11-wm/icewm/files/digest-icewm-1.0.8.6-r1
diff --git a/x11-wm/icewm/files/icewm b/x11-wm/icewm/files/icewm
deleted file mode 100755
index e73ee39adebb..000000000000
--- a/x11-wm/icewm/files/icewm
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-exec /usr/X11R6/bin/icewm
diff --git a/x11-wm/icewm/icewm-1.0.8.6-r1.ebuild b/x11-wm/icewm/icewm-1.0.8.6-r1.ebuild
new file mode 100644
index 000000000000..2c6e95fb1fbd
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.0.8.6-r1.ebuild
@@ -0,0 +1,34 @@
+#Author Nathaniel Hirsch <nh2@njit.edu>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.0.8.6-r1.ebuild,v 1.1 2001/10/12 01:04:39 hallski Exp $
+
+
+A=icewm-1.0.8-6.tar.gz
+S=${WORKDIR}/icewm-1.0.8
+DESCRIPTION="Ice Window Manager"
+SRC_URI="prdownloads.sourceforge.net/${PN}/${PN}-1.0.8-6.tar.gz"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11"
+
+src_compile(){
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/icewm
+ assert
+
+ emake || die
+}
+src_install(){
+ make prefix=${D}/usr \
+ DOCDIR=${S}/dummy \
+ sysconfdir=${D}/etc/X11/icewm \
+ install || die
+
+ dodoc BUGS CHANGES COPYING FAQ PLATFORMS README TODO VERSION
+ docinto html
+ dodoc doc/*.html
+ docinto sgml
+ dodoc doc/*.sgml
+}
+
+
diff --git a/x11-wm/icewm/icewm-1.0.8.6.ebuild b/x11-wm/icewm/icewm-1.0.8.6.ebuild
deleted file mode 100644
index 40e9adb80ea8..000000000000
--- a/x11-wm/icewm/icewm-1.0.8.6.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-#Author Nathaniel Hirsch <nh2@njit.edu>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.0.8.6.ebuild,v 1.4 2001/08/31 03:23:39 pm Exp $
-
-
-A=icewm-1.0.8-6.tar.gz
-S=${WORKDIR}/icewm-1.0.8
-DESCRIPTION="Ice Window Manager"
-SRC_URI="prdownloads.sourceforge.net/icewm/${A}"
-HOMEPAGE="www.icewm.org"
-
-DEPEND="virtual/x11"
-
-src_compile(){
- try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc
- try make
-}
-src_install(){
-
- try make prefix=${D}/usr/X11R6 DOCDIR=${S}/dummy \
- sysconfdir=${D}/etc install
- exeinto /usr/X11R6/bin/wm
- doexe ${FILESDIR}/icewm
- dodoc BUGS CHANGES COPYING FAQ PLATFORMS README TODO VERSION
- docinto html
- dodoc doc/*.html
- docinto sgml
- dodoc doc/*.sgml
-
-}
-