summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-02-26 11:01:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-02-26 11:01:30 +0000
commitd2e037c5aa7fae95db5970a20aaa833092e1d6e1 (patch)
treedaa9c0af904b54a972f959d43a9e8c72753966c6 /x11-wm/fluxbox/files
parentBug #81815, force depend on neon so that the bundled version isn't used. (diff)
downloadhistorical-d2e037c5aa7fae95db5970a20aaa833092e1d6e1.tar.gz
historical-d2e037c5aa7fae95db5970a20aaa833092e1d6e1.tar.bz2
historical-d2e037c5aa7fae95db5970a20aaa833092e1d6e1.zip
Patch to build libFbTk.{a,la,so}, and install it properly - this allows other applicationss to link against it.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'x11-wm/fluxbox/files')
-rw-r--r--x11-wm/fluxbox/files/0.9.12/fluxbox-0.9.12-make-FbTk-available-as-la.patch56
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.9.12-r21
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/files/0.9.12/fluxbox-0.9.12-make-FbTk-available-as-la.patch b/x11-wm/fluxbox/files/0.9.12/fluxbox-0.9.12-make-FbTk-available-as-la.patch
new file mode 100644
index 000000000000..6ab454c1a6d0
--- /dev/null
+++ b/x11-wm/fluxbox/files/0.9.12/fluxbox-0.9.12-make-FbTk-available-as-la.patch
@@ -0,0 +1,56 @@
+diff -Nuar fluxbox-0.9.12.orig/src/FbTk/Makefile.am fluxbox-0.9.12/src/FbTk/Makefile.am
+--- fluxbox-0.9.12.orig/src/FbTk/Makefile.am 2005-01-26 17:36:10.255652000 -0800
++++ fluxbox-0.9.12/src/FbTk/Makefile.am 2005-01-26 17:37:42.226670672 -0800
+@@ -1,4 +1,4 @@
+-noinst_LIBRARIES = libFbTk.a
++lib_LTLIBRARIES = libFbTk.la
+
+ AM_CPPFLAGS=@CPPFLAGS@
+
+@@ -15,7 +15,7 @@
+ imlib2_SOURCE= ImageImlib2.hh ImageImlib2.cc
+ endif
+
+-libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
++libFbTk_la_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
+ FileUtil.hh FileUtil.cc \
+ EventHandler.hh EventManager.hh EventManager.cc \
+ FbWindow.hh FbWindow.cc Font.cc Font.hh FontImp.hh \
+diff -Nuar fluxbox-0.9.12.orig/src/Makefile.am fluxbox-0.9.12/src/Makefile.am
+--- fluxbox-0.9.12.orig/src/Makefile.am 2004-11-15 12:40:45.000000000 -0800
++++ fluxbox-0.9.12/src/Makefile.am 2005-01-26 17:41:31.127872400 -0800
+@@ -120,4 +120,4 @@
+ ${REMEMBER_SOURCE} ${REGEXP_SOURCE} ${TOOLBAR_SOURCE}
+
+
+-LDADD=FbTk/libFbTk.a
++LDADD=FbTk/libFbTk.la
+diff -Nuar fluxbox-0.9.12.orig/util/Makefile.am fluxbox-0.9.12/util/Makefile.am
+--- fluxbox-0.9.12.orig/util/Makefile.am 2004-11-15 12:40:54.000000000 -0800
++++ fluxbox-0.9.12/util/Makefile.am 2005-01-26 17:41:50.346950656 -0800
+@@ -5,7 +5,7 @@
+ bin_PROGRAMS= bsetroot
+ bsetroot_SOURCES= bsetroot.cc bsetroot.hh
+ bsetroot_LDADD= ../src/FbRootWindow.o ../src/FbAtoms.o \
+- ../src/FbTk/libFbTk.a
++ ../src/FbTk/libFbTk.la
+
+ MAINTAINERCLEANFILES= Makefile.in
+ EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \
+diff -Nuar fluxbox-0.9.12.orig/util/fbrun/Makefile.am fluxbox-0.9.12/util/fbrun/Makefile.am
+--- fluxbox-0.9.12.orig/util/fbrun/Makefile.am 2004-11-15 12:40:54.000000000 -0800
++++ fluxbox-0.9.12/util/fbrun/Makefile.am 2005-01-26 17:55:37.061270976 -0800
+@@ -2,7 +2,9 @@
+ INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk
+ bin_PROGRAMS= fbrun
+ fbrun_SOURCES= FbRun.hh FbRun.cc main.cc fbrun.xpm
+-fbrun_LDADD= ${FLUXBOX_SRC_DIR}FbTk/libFbTk.a
+
+-${FLUXBOX_SRC_DIR}FbTk/libFbTk.a:
+- cd ${FLUXBOX_SRC_DIR}FbTk && make
+\ No newline at end of file
++FbTkDir= ${FLUXBOX_SRC_DIR}FbTk
++fbrun_LDADD= $(FbTkDir)/libFbTk.la
++
++$(fbrun_LDADD):
++ cd $(FbTkDir) && make
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.9.12-r2 b/x11-wm/fluxbox/files/digest-fluxbox-0.9.12-r2
new file mode 100644
index 000000000000..9f51ea28b9fd
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.9.12-r2
@@ -0,0 +1 @@
+MD5 398f4e10d88b47507ea309968340961c fluxbox-0.9.12.tar.bz2 648685