summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-03-26 23:03:42 +0000
committerAlex Alexander <wired@gentoo.org>2011-03-26 23:03:42 +0000
commitc300ce535ef34c18bdc866e4aa214658dbb87f34 (patch)
tree83eed421ee6fa773601edc44444339eeb822a486 /x11-themes/gtk-engines-qtcurve
parentUse PyPI mirrors. (diff)
downloadhistorical-c300ce535ef34c18bdc866e4aa214658dbb87f34.tar.gz
historical-c300ce535ef34c18bdc866e4aa214658dbb87f34.tar.bz2
historical-c300ce535ef34c18bdc866e4aa214658dbb87f34.zip
version bump
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.7.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 180cddf2047e..0ff6a073c7c3 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.105 2011/03/05 13:51:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.106 2011/03/26 23:03:42 wired Exp $
+
+*gtk-engines-qtcurve-1.8.7 (26 Mar 2011)
+
+ 26 Mar 2011; Alex Alexander <wired@gentoo.org>
+ +gtk-engines-qtcurve-1.8.7.ebuild:
+ version bump
05 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gtk-engines-qtcurve-1.6.4.ebuild:
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.7.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.7.ebuild
new file mode 100644
index 000000000000..dbfd5554c44c
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-1.8.7.ebuild,v 1.1 2011/03/26 23:03:42 wired Exp $
+
+EAPI=4
+inherit cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ mozilla? (
+ || (
+ >=www-client/firefox-3.0
+ >=www-client/firefox-bin-3.0
+ )
+ )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DQTC_OLD_MOZILLA=OFF"
+ "-QTC_USE_CAIRO_FOR_ARROWS=ON"
+ $(cmake-utils_use mozilla QTC_MODIFY_MOZILLA)
+ )
+ cmake-utils_src_configure
+}