summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-06-19 11:38:29 +0000
committerTroy Dack <tad@gentoo.org>2003-06-19 11:38:29 +0000
commit037b16cbbb3a906c285f7f3a3d7f5f26919b83bd (patch)
tree2ccf83162a23145b37359dd2a50802c6803f02fa /x11-themes/fusionx-aqua
parentInitial import. Bug #22784 (diff)
downloadhistorical-037b16cbbb3a906c285f7f3a3d7f5f26919b83bd.tar.gz
historical-037b16cbbb3a906c285f7f3a3d7f5f26919b83bd.tar.bz2
historical-037b16cbbb3a906c285f7f3a3d7f5f26919b83bd.zip
Initial import. Bug #22784
Diffstat (limited to 'x11-themes/fusionx-aqua')
-rw-r--r--x11-themes/fusionx-aqua/Manifest3
-rw-r--r--x11-themes/fusionx-aqua/files/digest-fusionx-aqua-1.11
-rw-r--r--x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild49
3 files changed, 52 insertions, 1 deletions
diff --git a/x11-themes/fusionx-aqua/Manifest b/x11-themes/fusionx-aqua/Manifest
index 43922a2bedfd..04ce16b58264 100644
--- a/x11-themes/fusionx-aqua/Manifest
+++ b/x11-themes/fusionx-aqua/Manifest
@@ -1,2 +1,3 @@
-MD5 66a1ff89e69eea97503e0e30db31ab8b fusionx-aqua-1.1.ebuild 1808
+MD5 df7a9fcf66f86abd088212034262023d fusionx-aqua-1.1.ebuild 1915
+MD5 698bb3878112b3eacb9b3ae8fb1ee4b5 ChangeLog 438
MD5 b4dda0bfb72a5212167d14e033690873 files/digest-fusionx-aqua-1.1 72
diff --git a/x11-themes/fusionx-aqua/files/digest-fusionx-aqua-1.1 b/x11-themes/fusionx-aqua/files/digest-fusionx-aqua-1.1
new file mode 100644
index 000000000000..700f960a44d6
--- /dev/null
+++ b/x11-themes/fusionx-aqua/files/digest-fusionx-aqua-1.1
@@ -0,0 +1 @@
+MD5 d2689ccf68343e7e0d05dd4295bbec4c 5296-FusionX-Aqua-1.1.tar.gz 24913
diff --git a/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild b/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild
new file mode 100644
index 000000000000..c3f321b5018d
--- /dev/null
+++ b/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fusionx-aqua/fusionx-aqua-1.1.ebuild,v 1.1 2003/06/19 11:38:11 tad Exp $
+
+inherit kde-base || die "Can't inherit kde-base!"
+need-kde 3.1
+
+MY_P="FusionX-Aqua-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The stylish \"Fusion X Aqua\" theme for KDE 3.1. This was inspired by Max Rudberg's BBX appearance theme designed for use with Apple's OS X operating system."
+HOMEPAGE="http://www.kdelook.org/content/show.php?content=5296"
+SRC_URI="http://www.kdelook.org/content/files/5296-${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="kde-base/kdebase"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
+src_compile(){
+ # nothing to compile, but don't want the eclass to try to compile anything
+ return 0
+}
+
+src_install(){
+ mkdir -p ${D}/${KDEDIR}/share/apps/kstyle
+ cp -R -f ${WORKDIR}/${MY_P}/pixmaps ${D}/${KDEDIR}/share/apps/kstyle/ || die
+ cp -R -f ${WORKDIR}/${MY_P}/themes ${D}/${KDEDIR}/share/apps/kstyle/ || die
+ mkdir -p ${D}/${KDEDIR}/share/apps/kwin
+ cp -R -f ${WORKDIR}/${MY_P}/icewm-themes ${D}/${KDEDIR}/share/apps/kwin || die
+ mkdir -p ${D}/${KDEDIR}/share/apps/kdisplay
+ cp -R -f ${WORKDIR}/${MY_P}/color-schemes ${D}/${KDEDIR}/share/apps/kdisplay || die
+ dodoc ${WORKDIR}/${MY_P}/{CREDITS,README,CHANGELOG}
+}
+
+pkg_postinst(){
+ einfo "This theme is an IceWM pixmap theme for KDE."
+ einfo ""
+ einfo "To use this theme set the following options in the"
+ einfo "KDE Control Center:"
+ einfo " o Appearance & Themes"
+ einfo " - Style = \"fusionx-aqua\""
+ einfo " - Window Decorations = \"IceWM\""
+ einfo " - Configuration [IceWM] = \"fusionX-aqua\""
+ einfo ""
+ einfo "To make the theme visible in any currently running KDE session"
+ einfo "execute the following command from a shell or the"
+ einfo "KDE \"Run Command\" dialog:"
+ einfo " kinstalltheme"
+
+} \ No newline at end of file