summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2005-12-24 02:50:41 +0000
committerJory Pratt <anarchy@gentoo.org>2005-12-24 02:50:41 +0000
commit49c8b71a109f1f848c38f46a3f6bd22e500f35b2 (patch)
tree823b24ec6f77105eafb8a1f792d084fb557500b0 /x11-plugins
parentInitial commit (bug #70847). (diff)
downloadhistorical-49c8b71a109f1f848c38f46a3f6bd22e500f35b2.tar.gz
historical-49c8b71a109f1f848c38f46a3f6bd22e500f35b2.tar.bz2
historical-49c8b71a109f1f848c38f46a3f6bd22e500f35b2.zip
revision bump to support thunderbird-1.5rc2"
Package-Manager: portage-2.0.53
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/ChangeLog8
-rw-r--r--x11-plugins/enigmail/Manifest4
-rw-r--r--x11-plugins/enigmail/enigmail-0.93.1-r1.ebuild131
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.93.1-r13
4 files changed, 144 insertions, 2 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index 1e6e0ff8e487..cfa652c36678 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.1 2005/12/06 02:40:57 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.2 2005/12/24 02:50:41 anarchy Exp $
+
+*enigmail-0.93.1-r1 (24 Dec 2005)
+
+ 24 Dec 2005; Jory A. Pratt <anarchy@gentoo.org>
+ +enigmail-0.93.1-r1.ebuild:
+ revision bump to support thunderbird-1.5-rc2
*enigmail-0.93.1 (06 Dec 2005)
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index 690c792c7f00..c642f9469e9c 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,7 +1,9 @@
-MD5 581bbdccfff09ea4fe86a88c7ddcf71a ChangeLog 488
+MD5 388078e03021091a494ca20b6a7beb30 ChangeLog 651
+MD5 03fa3f644e7bc978462247a65fd6547f enigmail-0.93.1-r1.ebuild 4020
MD5 05901c77a7e603f74cd04ead1e8c2831 enigmail-0.93.1.ebuild 4017
MD5 f6da2f617f170f8bbc915d81d7588fa1 files/50_enigmail_no_upgrade.patch 633
MD5 6bbab0286558a86eb8175fb601b43678 files/70_enigmail-fix.patch 343
MD5 a9e5f97457fe82c26106daa0a6e17677 files/digest-enigmail-0.93.1 208
+MD5 40691bae6873e691788ffc3d645795dc files/digest-enigmail-0.93.1-r1 208
MD5 cc5756b8c7af5c88b248b86c73fc5c8d files/firefox-1.1-visibility.patch 930
MD5 d048ab0ca56f9151afdebcff86b18438 metadata.xml 303
diff --git a/x11-plugins/enigmail/enigmail-0.93.1-r1.ebuild b/x11-plugins/enigmail/enigmail-0.93.1-r1.ebuild
new file mode 100644
index 000000000000..baa80a0e10e4
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.93.1-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.93.1-r1.ebuild,v 1.1 2005/12/24 02:50:41 anarchy Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib
+
+EMVER=${PV}
+TBVER="1.5rc2"
+IPCVER="1.1.3"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz
+ http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz "
+
+KEYWORDS="-*"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-1.5_rc2"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ epatch ${FILESDIR}/firefox-1.1-visibility.patch
+
+ # Unpack the enigmail plugin
+ for x in ipc enigmail; do
+ mv ${WORKDIR}/${x} ${S}/extensions || die "mv failed"
+ cd ${S}/extensions/${x} || die "cd failed"
+ makemake # from mozconfig.eclass
+ done
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C extensions/ipc || die "make ipc failed"
+ emake -C extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.93.1-r1 b/x11-plugins/enigmail/files/digest-enigmail-0.93.1-r1
new file mode 100644
index 000000000000..657403383cf6
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.93.1-r1
@@ -0,0 +1,3 @@
+MD5 d0de6d3968dc6a38e60578d6cf9098fd enigmail-0.93.1.tar.gz 405011
+MD5 64ba4c6e3b52568468c4f6680ec7e679 ipc-1.1.3.tar.gz 102593
+MD5 de9476d1a7807627985304bfa69085a3 thunderbird-1.5rc2-source.tar.bz2 35187072