summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-10-12 11:17:04 +0000
committerSimon Stelling <blubb@gentoo.org>2006-10-12 11:17:04 +0000
commita5ebea55ce1170c61402436f506a92aeeab5e25b (patch)
tree0b34f70dde872161acf1f5df7bb101dc98917752 /x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild
parentStable on ppc; bug #150819 (diff)
downloadhistorical-a5ebea55ce1170c61402436f506a92aeeab5e25b.tar.gz
historical-a5ebea55ce1170c61402436f506a92aeeab5e25b.tar.bz2
historical-a5ebea55ce1170c61402436f506a92aeeab5e25b.zip
fix bug 142131
Package-Manager: portage-2.1.2_pre2-r5
Diffstat (limited to 'x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild')
-rw-r--r--x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild b/x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..ddc577923a2f
--- /dev/null
+++ b/x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/wmupmon-0.1.3-r1.ebuild,v 1.1 2006/10/12 11:17:04 blubb Exp $
+
+inherit eutils
+
+DESCRIPTION="wmUpMon is a program to monitor your Uptime"
+HOMEPAGE="http://j-z-s.com/projects/index.php?project=wmupmon"
+SRC_URI="http://j-z-s.com/projects/downloads/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/${P}-arraysize.patch
+}
+
+src_compile()
+{
+ econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ einstall || die "make install failed"
+ dodoc AUTHORS README THANKS ChangeLog
+}