summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-20 12:33:48 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-20 12:33:48 +0000
commitb2fcfa8f401127b759a991715873ae2ea2a8bd84 (patch)
tree60ed9c93c801fbeb0272474f15a040e9c933ed74 /x11-plugins/wmcalendar
parentVersion bump. Closing #45072. (diff)
downloadhistorical-b2fcfa8f401127b759a991715873ae2ea2a8bd84.tar.gz
historical-b2fcfa8f401127b759a991715873ae2ea2a8bd84.tar.bz2
historical-b2fcfa8f401127b759a991715873ae2ea2a8bd84.zip
Added Makefile patch. Closing bug #28951.
Diffstat (limited to 'x11-plugins/wmcalendar')
-rw-r--r--x11-plugins/wmcalendar/ChangeLog6
-rw-r--r--x11-plugins/wmcalendar/Manifest3
-rw-r--r--x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch30
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-plugins/wmcalendar/ChangeLog b/x11-plugins/wmcalendar/ChangeLog
index a330a352723f..a31648ecec07 100644
--- a/x11-plugins/wmcalendar/ChangeLog
+++ b/x11-plugins/wmcalendar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmcalendar
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcalendar/ChangeLog,v 1.1 2004/03/06 02:20:55 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcalendar/ChangeLog,v 1.2 2004/03/20 12:33:48 pyrania Exp $
+
+ 20 Mar 2004; Markus Nigbur <pyrania@gentoo.org>
+ files/wmcalendar-0.5.0.makefile.patch:
+ Added Makefile patch. Closing bug #28951.
*wmcalendar-0.5.0 (06 Mar 2004)
diff --git a/x11-plugins/wmcalendar/Manifest b/x11-plugins/wmcalendar/Manifest
index 281cf858a424..b35a9258ddf1 100644
--- a/x11-plugins/wmcalendar/Manifest
+++ b/x11-plugins/wmcalendar/Manifest
@@ -1,3 +1,4 @@
MD5 7b41b5019e40f39382139dd5d80f7f42 wmcalendar-0.5.0.ebuild 912
-MD5 bc7c782e435a053633c912f93ed89593 ChangeLog 354
+MD5 fe73e9920bfc2635109b72b24f85824d ChangeLog 490
MD5 e1445dfb0ac0d0dd189f22956e61de10 files/digest-wmcalendar-0.5.0 67
+MD5 54f3e7d4eb228c47d0712426fff78d15 files/wmcalendar-0.5.0.makefile.patch 980
diff --git a/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch b/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch
new file mode 100644
index 000000000000..6c13f109a469
--- /dev/null
+++ b/x11-plugins/wmcalendar/files/wmcalendar-0.5.0.makefile.patch
@@ -0,0 +1,30 @@
+diff -ur wmcalendar-0.5.0/Src/Makefile /wmcalendar-0.5.0/Src/Makefile
+--- wmcalendar-0.5.0/Src/Makefile 2003-07-15 17:19:26.000000000 +0200
++++ /wmcalendar-0.5.0/Src/Makefile 2003-09-17 08:36:48.000000000 +0200
+@@ -1,4 +1,7 @@
+-CC = gcc
++ifndef CC
++ CC = gcc
++endif
++
+ INCLUDES = `pkg-config --cflags gtk+-2.0` -I.
+ LFLAGS = `pkg-config --libs gtk+-2.0`
+
+@@ -6,7 +9,7 @@
+ #INCLUDES = `gtk12-config --cflags` -I.
+ #LFLAGS = `gtk12-config --libs`
+ X11BASE = /usr/X11R6
+-CFLAGS = $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
++MY_CFLAGS = $(CFLAGS) $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
+ INCDIR = -I$(X11BASE)/include/X11 -I$(X11BASE)/include -I$/usr/include -I$/usr/local/include
+ DESTDIR= /usr/local
+ LIBDIR = -L/usr/lib -L${X11BASE}/lib -L/usr/local/lib
+@@ -24,7 +27,7 @@
+ calendar.o
+
+ .c.o:
+- $(CC) $(CFLAGS) -D`uname -s` -DHAVE_SYS_TIME_H -c $< -o $*.o $(INCDIR)
++ $(CC) $(MY_CFLAGS) -D`uname -s` -DHAVE_SYS_TIME_H -c $< -o $*.o $(INCDIR)
+
+
+ all: wmCalendar.o wmCalendar