summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-24 14:48:18 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-24 14:48:18 +0000
commit610553e285fd5cf11c1b0587047de0072087f391 (patch)
tree51e8ce8ac37e02d2dda05910d5a86ea1b3d94766 /x11-plugins/thinkhdaps
parentMigrate changes from Gentoo Prefix overlay. KEYWORDS, change to EAPI3, add co... (diff)
downloadhistorical-610553e285fd5cf11c1b0587047de0072087f391.tar.gz
historical-610553e285fd5cf11c1b0587047de0072087f391.tar.bz2
historical-610553e285fd5cf11c1b0587047de0072087f391.zip
Initial commit for thinkhdaps
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/thinkhdaps')
-rw-r--r--x11-plugins/thinkhdaps/ChangeLog10
-rw-r--r--x11-plugins/thinkhdaps/Manifest4
-rw-r--r--x11-plugins/thinkhdaps/metadata.xml9
-rw-r--r--x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/thinkhdaps/ChangeLog b/x11-plugins/thinkhdaps/ChangeLog
new file mode 100644
index 000000000000..3bd9a28dd313
--- /dev/null
+++ b/x11-plugins/thinkhdaps/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-plugins/thinkhdaps
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/thinkhdaps/ChangeLog,v 1.1 2010/08/24 14:48:18 xmw Exp $
+
+*thinkhdaps-0.2.1 (24 Aug 2010)
+
+ 24 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org>
+ +thinkhdaps-0.2.1.ebuild, +metadata.xml:
+ Initial commit for thinkhdaps. Fixes bug #324111.
+
diff --git a/x11-plugins/thinkhdaps/Manifest b/x11-plugins/thinkhdaps/Manifest
new file mode 100644
index 000000000000..387964e544d0
--- /dev/null
+++ b/x11-plugins/thinkhdaps/Manifest
@@ -0,0 +1,4 @@
+DIST thinkhdaps-0.2.1.tar.gz 91489 RMD160 f709bce70fac346d46b6f188c78457f3a2f30f76 SHA1 8ee8ebb54623e48dccbd01a267818154200b41c5 SHA256 826fd9a1153adb49bc46a81ae60cc01cd77ba6ade7e135493908ca8185825d18
+EBUILD thinkhdaps-0.2.1.ebuild 733 RMD160 78a1824bf45a861e797ce3aa8be01e5475f3b9e4 SHA1 39f370d88b696e2a3569d462f39539a2f3d6412d SHA256 944fec239aa17d226fdfe569d7c1a53ace18f05b66dfea981a86c284d5b40708
+MISC ChangeLog 395 RMD160 f12dbcc745b8d2ca11c85ca0adb33dacc925f9b1 SHA1 804985a6cc25a0cbb3119d45e9476734010803a0 SHA256 66dbcaa9ad5bb367b00989fc34ae15627f2b9a8a4c705457d1d47cbb5af5e980
+MISC metadata.xml 250 RMD160 531d16ce53df413a3132df5f64a832f0b43afff1 SHA1 3fc78a8c89561c5ef16d82e2aad920a96d68ea81 SHA256 59ae49b73b8f2069b77421fa255138ba059c5588ee8ca7f7a5b73da2a6fb8be2
diff --git a/x11-plugins/thinkhdaps/metadata.xml b/x11-plugins/thinkhdaps/metadata.xml
new file mode 100644
index 000000000000..80dffe809356
--- /dev/null
+++ b/x11-plugins/thinkhdaps/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber (xmw)</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
new file mode 100644
index 000000000000..03f5ec0f0704
--- /dev/null
+++ b/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/thinkhdaps/thinkhdaps-0.2.1.ebuild,v 1.1 2010/08/24 14:48:18 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit base python
+
+DESCRIPTION="A PyGTK based HDAPS monitor"
+HOMEPAGE="http://thpani.at/projects/thinkhdaps/"
+SRC_URI="http://thpani.at/media/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/libgnome-python:2
+ dev-python/pygobject:2
+ dev-python/pygtk:2"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ econf --enable-desktop PYTHON=$(PYTHON -2 --absolute-path)
+}