summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-10-08 02:57:22 +0000
committerAron Griffis <agriffis@gentoo.org>2004-10-08 02:57:22 +0000
commit239dda48e1affdd14e6655e4ef0b8efb9e460dcc (patch)
tree563e0c44b365fbb25aed942e2049c4271b171560 /x11-misc/xcut/xcut-0.2.ebuild
parentia64 stable #66667 (diff)
downloadhistorical-239dda48e1affdd14e6655e4ef0b8efb9e460dcc.tar.gz
historical-239dda48e1affdd14e6655e4ef0b8efb9e460dcc.tar.bz2
historical-239dda48e1affdd14e6655e4ef0b8efb9e460dcc.zip
Add xcut to portage. Thanks to Aaron Brooks for the ebuild
Diffstat (limited to 'x11-misc/xcut/xcut-0.2.ebuild')
-rw-r--r--x11-misc/xcut/xcut-0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/xcut/xcut-0.2.ebuild b/x11-misc/xcut/xcut-0.2.ebuild
new file mode 100644
index 000000000000..82ed4739bd7b
--- /dev/null
+++ b/x11-misc/xcut/xcut-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcut/xcut-0.2.ebuild,v 1.1 2004/10/08 02:57:22 agriffis Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Commandline tool to manipulate the X11 cut and paste buffers"
+HOMEPAGE="http://xcut.sourceforge.net"
+SRC_URI="mirror://sourceforge/xcut/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ xmkmf || die
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR=${D} install.man || die "make install.man failed"
+ dodoc README || die "dodoc failed"
+}