summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-15 21:17:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-15 21:17:56 +0000
commitf9e3592060aec7e067072a7b537744e0325e63d1 (patch)
tree8dc10625c1f16602a4e48701dd1846033e592dff /x11-misc/root-portal
parentSparc changes from Kumba (diff)
downloadhistorical-f9e3592060aec7e067072a7b537744e0325e63d1.tar.gz
historical-f9e3592060aec7e067072a7b537744e0325e63d1.tar.bz2
historical-f9e3592060aec7e067072a7b537744e0325e63d1.zip
gcc3 patch #31222
Diffstat (limited to 'x11-misc/root-portal')
-rw-r--r--x11-misc/root-portal/files/0.4.11-gcc3.patch66
-rw-r--r--x11-misc/root-portal/root-portal-0.4.11.ebuild47
2 files changed, 92 insertions, 21 deletions
diff --git a/x11-misc/root-portal/files/0.4.11-gcc3.patch b/x11-misc/root-portal/files/0.4.11-gcc3.patch
new file mode 100644
index 000000000000..387aaa8cadcd
--- /dev/null
+++ b/x11-misc/root-portal/files/0.4.11-gcc3.patch
@@ -0,0 +1,66 @@
+diff -ur root-portal-0.4.11.orig/src/config/configuration.h root-portal-0.4.11/src/config/configuration.h
+--- root-portal-0.4.11.orig/src/config/configuration.h 2003-10-15 16:00:20.512226040 -0400
++++ root-portal-0.4.11/src/config/configuration.h 2003-10-15 16:10:12.625211184 -0400
+@@ -14,6 +14,7 @@
+ #endif
+
+ #include <vector>
++#include <assert.h>
+ using namespace std;
+
+ class ModuleModifier;
+diff -ur root-portal-0.4.11.orig/src/dataset.h root-portal-0.4.11/src/dataset.h
+--- root-portal-0.4.11.orig/src/dataset.h 2003-10-15 16:00:20.466233032 -0400
++++ root-portal-0.4.11/src/dataset.h 2003-10-15 16:08:13.625301920 -0400
+@@ -11,6 +11,7 @@
+ #include <string>
+ #include <cstdlib>
+ #include <cstdio>
++#include <assert.h>
+ using namespace std;
+
+ class BadDataType {};
+diff -ur root-portal-0.4.11.orig/src/modules/filetail/filetail.h root-portal-0.4.11/src/modules/filetail/filetail.h
+--- root-portal-0.4.11.orig/src/modules/filetail/filetail.h 2003-10-15 16:00:20.483230448 -0400
++++ root-portal-0.4.11/src/modules/filetail/filetail.h 2003-10-15 16:05:47.017589680 -0400
+@@ -2,6 +2,7 @@
+ #define FILETAIL_H
+
+ #include <cstdio>
++#include <assert.h>
+ using namespace std;
+
+ #include "../../module.h"
+diff -ur root-portal-0.4.11.orig/src/modules/process/process.h root-portal-0.4.11/src/modules/process/process.h
+--- root-portal-0.4.11.orig/src/modules/process/process.h 2003-10-15 16:00:20.484230296 -0400
++++ root-portal-0.4.11/src/modules/process/process.h 2003-10-15 16:06:51.646764552 -0400
+@@ -6,6 +6,7 @@
+ #include <cstdlib>
+ #include <cstdio>
+ #include <vector>
++#include <assert.h>
+ using namespace std;
+
+ #include "../../module.h"
+diff -ur root-portal-0.4.11.orig/src/modules/roottext/roottext.h root-portal-0.4.11/src/modules/roottext/roottext.h
+--- root-portal-0.4.11.orig/src/modules/roottext/roottext.h 2003-10-15 16:00:20.486229992 -0400
++++ root-portal-0.4.11/src/modules/roottext/roottext.h 2003-10-15 16:07:23.406936272 -0400
+@@ -9,6 +9,7 @@
+ #include "../../rootwindow.h"
+ #include "../../drawing_area.h"
+ #include <vector>
++#include <assert.h>
+ using namespace std;
+
+ typedef unsigned long Pixel;
+diff -ur root-portal-0.4.11.orig/src/path.h root-portal-0.4.11/src/path.h
+--- root-portal-0.4.11.orig/src/path.h 2003-10-15 16:00:20.467232880 -0400
++++ root-portal-0.4.11/src/path.h 2003-10-15 16:11:46.954870896 -0400
+@@ -3,6 +3,7 @@
+
+ #include <vector>
+ #include <string>
++#include <assert.h>
+ using namespace std;
+
+ class Path
diff --git a/x11-misc/root-portal/root-portal-0.4.11.ebuild b/x11-misc/root-portal/root-portal-0.4.11.ebuild
index 5585e28ef4df..ea8cfd36f1d2 100644
--- a/x11-misc/root-portal/root-portal-0.4.11.ebuild
+++ b/x11-misc/root-portal/root-portal-0.4.11.ebuild
@@ -1,38 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.4.11.ebuild,v 1.4 2003/09/05 23:18:18 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.4.11.ebuild,v 1.5 2003/10/15 21:17:56 vapier Exp $
inherit debug
-IUSE="gnome"
-
DESCRIPTION="A program to draw text and graphs in the root window"
HOMEPAGE="http://root-portal.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="~x86 ~ppc"
+IUSE="gnome"
# Build-time dependencies, such as
# ssl? ( >=openssl-0.9.6b )
# >=perl-5.6.1-r1
-DEPEND="
- virtual/x11
+DEPEND="virtual/x11
=x11-libs/gtk+-1.2*
>=gnome-base/ORBit-0.5.7
>=gnome-base/gnome-libs-1.4.0
<gnome-base/gnome-panel-2
>=dev-libs/libxml-1.8.16 "
-
-
# the tabulated section is only needed if Gnome is in USE, but their disable-gnome doesn't work for now.
-#RDEPEND=""
-
-S="${WORKDIR}/${P}"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
src_compile() {
local myconf="--enable-debug --enable-test --enable-crash-debug"
@@ -42,17 +38,26 @@ src_compile() {
# use gnome && myconf="${myconf} --enable-gnometext-builtin --enable-shell-builtin"
# use gnome || myconf="${myconf} --without-gnome --without-gnome-libs --disable-gnometext-builtin --disable-shell-builtin"
- myconf="${myconf} --enable-gnometext --enable-shell"
- myconf="${myconf} --enable-console --enable-fifo --enable-filetail"
- myconf="${myconf} --enable-graph --enable-process-builtin --enable-modifier"
- myconf="${myconf} --enable-networkload --enable-remote --enable-roottext"
- myconf="${myconf} --enable-systemload --enable-consoledump"
- econf ${myconf} || die "configure failure. please file a bugreport"
-
+ econf \
+ --enable-gnometext \
+ --enable-shell \
+ --enable-console \
+ --enable-fifo \
+ --enable-filetail \
+ --enable-graph \
+ --enable-process-builtin \
+ --enable-modifier \
+ --enable-networkload \
+ --enable-remote \
+ --enable-roottext \
+ --enable-systemload \
+ --enable-consoledump \
+ ${myconf} \
+ || die "configure failure. please file a bugreport"
emake || die "compile failure. please file a bugreport"
}
src_install() {
- einstall
- dodoc PACKAGING README NEWS ChangeLog BUGS AUTHORS COPYING INSTALL README.help UNINSTALL TODO
+ einstall || die
+ dodoc PACKAGING README NEWS ChangeLog BUGS AUTHORS README.help TODO
}