summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-18 13:14:09 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-18 13:14:09 +0000
commit5a088c0a2b361d36642821caaa9c7fe7dc1eb433 (patch)
tree261eb82cf6c25854990799fece7d9bc553971dfa /x11-misc/googleearth/googleearth-4.ebuild
parentStable on sparc (diff)
downloadhistorical-5a088c0a2b361d36642821caaa9c7fe7dc1eb433.tar.gz
historical-5a088c0a2b361d36642821caaa9c7fe7dc1eb433.tar.bz2
historical-5a088c0a2b361d36642821caaa9c7fe7dc1eb433.zip
Revert the ati/nvidia changes, as SRC_URI doesn't work. Request by jakub, blame him
Package-Manager: portage-2.1.2
Diffstat (limited to 'x11-misc/googleearth/googleearth-4.ebuild')
-rw-r--r--x11-misc/googleearth/googleearth-4.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/x11-misc/googleearth/googleearth-4.ebuild b/x11-misc/googleearth/googleearth-4.ebuild
index d614c35ee64a..495c01aa7cc3 100644
--- a/x11-misc/googleearth/googleearth-4.ebuild
+++ b/x11-misc/googleearth/googleearth-4.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.ebuild,v 1.2 2007/01/13 09:56:05 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.ebuild,v 1.3 2007/01/18 13:14:09 armin76 Exp $
inherit eutils fdo-mime
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="http://earth.google.com/"
-SRC_URI="http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
- video_cards_fglrx? ( http://dev.gentooexperimental.org/~anarchy/libGL.so.1 )"
+SRC_URI="http://dl.google.com/earth/GE4/GoogleEarthLinux.bin"
LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
SLOT="0"
KEYWORDS="~x86 ~amd64"
RESTRICT="mirror strip"
-IUSE="video_cards_fglrx"
+IUSE=""
RDEPEND="x86? (
media-libs/fontconfig
@@ -28,20 +27,19 @@ RDEPEND="x86? (
x11-libs/libXrender )
<virtual/x11-7.0 ) )
amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-baselibs
- || (
- >=app-emulation/emul-linux-x86-xlibs-7.0
- x11-drivers/nvidia-drivers
- x11-drivers/nvidia-legacy-drivers
- video_cards_fglrx? ( x11-drivers/ati-drivers )
- <x11-drivers/ati-drivers-8.28.8 ) )
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ x11-drivers/nvidia-legacy-drivers
+ <x11-drivers/ati-drivers-8.28.8 ) )
media-fonts/ttf-bitstream-vera"
S="${WORKDIR}"
src_unpack() {
- unpack_makeself GoogleEarthLinux.bin
+ unpack_makeself
# make the postinst scripts behave
sed -i -e 's:$SETUP_INSTALLPATH/::' \
-e "s:^xdg-mime:linux/xdg/xdg-mime:" \
@@ -79,10 +77,6 @@ src_install() {
# make sure we install with correct permissions
fowners -R root:root /opt/${PN}
fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
-
- if use video_cards_fglrx; then
- mv ${DISTDIR}/libGL.so.1 ${D}/opt/${PN}
- fi
}
pkg_postinst() {