summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 05:56:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 05:56:34 +0000
commiteb8f1f917415dd806f074d74a911a03baab910e5 (patch)
treea89b1db7ddf5fdfd205814540c3610108e49351e /x11-misc/entrance
parentold (diff)
downloadhistorical-eb8f1f917415dd806f074d74a911a03baab910e5.tar.gz
historical-eb8f1f917415dd806f074d74a911a03baab910e5.tar.bz2
historical-eb8f1f917415dd806f074d74a911a03baab910e5.zip
hidden support for gentooed theme ... thx atmos ;)
Diffstat (limited to 'x11-misc/entrance')
-rw-r--r--x11-misc/entrance/entrance-0.9.0.20040207.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/x11-misc/entrance/entrance-0.9.0.20040207.ebuild b/x11-misc/entrance/entrance-0.9.0.20040207.ebuild
index afc14c540545..30c8d404ef19 100644
--- a/x11-misc/entrance/entrance-0.9.0.20040207.ebuild
+++ b/x11-misc/entrance/entrance-0.9.0.20040207.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20040207.ebuild,v 1.1 2004/02/08 00:47:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.20040207.ebuild,v 1.2 2004/02/08 05:56:34 vapier Exp $
inherit enlightenment eutils
@@ -9,6 +9,7 @@ HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
SRC_URI="${SRC_URI}
mirror://gentoo/extraicons-1.tar.bz2
http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+# http://www.atmos.org/files/gentooed-src.tar.gz"
IUSE="${IUSE} pam"
@@ -20,6 +21,20 @@ DEPEND="virtual/x11
>=media-libs/edje-0.0.1.20031020
>=x11-libs/esmart-0.0.2.20031025"
+src_unpack() {
+ enlightenment_src_unpack
+ if [ -d gentooed ] ; then
+ mv gentooed ${S}/data/themes/
+ cd ${S}/data/themes
+ sed -i '/^SUBDIRS/s:$: gentooed:' Makefile.am
+ cp default/{Makefile.am,build_theme.sh} gentooed/
+ cd gentooed
+ ln -s images img
+ sed -i 's:default:gentooed:g' Makefile.am build_theme.sh
+ sed -i 's:\(data/themes/default/Makefile\):\1 data/themes/gentooed/Makefile:' ${S}/configure.in
+ fi
+}
+
src_compile() {
if [ `use pam` ] ; then
export MY_ECONF="--with-auth-mode=pam"