summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
commit75d2ae7f5ac1e07c4b8bdf6df40543df4ce1eb69 (patch)
treec23ff1504afe00d75203bbb49dbefd02a970dafe /x11-libs
parent*** empty log message *** (diff)
downloadhistorical-75d2ae7f5ac1e07c4b8bdf6df40543df4ce1eb69.tar.gz
historical-75d2ae7f5ac1e07c4b8bdf6df40543df4ce1eb69.tar.bz2
historical-75d2ae7f5ac1e07c4b8bdf6df40543df4ce1eb69.zip
*** empty log message ***
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/fltk-1.0.10-r1.ebuild35
-rw-r--r--x11-libs/gtk+/gtk+-1.2.9.ebuild47
-rw-r--r--x11-libs/libPropList/libPropList-0.10.1-r2.ebuild31
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r1.ebuild42
-rw-r--r--x11-libs/qt-x11/files/digest-qt-x11-2.3.01
-rw-r--r--x11-libs/qt-x11/qt-x11-2.2.4-r1.ebuild105
6 files changed, 261 insertions, 0 deletions
diff --git a/x11-libs/fltk/fltk-1.0.10-r1.ebuild b/x11-libs/fltk/fltk-1.0.10-r1.ebuild
new file mode 100644
index 000000000000..d23044aac677
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.0.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.0.10-r1.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+SRC_URI="ftp://ftp.fltk.org/pub/fltk/${PV}/${P}-source.tar.bz2"
+HOMEPAGE="http://www.fltk.org"
+DEPEND=">=x11-base/xfree-4.0.1
+ opengl? ( >=media-libs/mesa-3.4 )"
+
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} --enable-shared
+ if [ -z "`use opengl`" ]
+ then
+ cp config.h config.orig
+ sed -e "s:#define HAVE_GL.*:#define HAVE_GL 0:" \
+ config.orig > config.h
+ fi
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 install
+ dodoc CHANGES COPYING README*
+ mv ${D}/usr/X11R6/share/doc/fltk ${D}/usr/share/doc/${PF}/html
+
+}
+
diff --git a/x11-libs/gtk+/gtk+-1.2.9.ebuild b/x11-libs/gtk+/gtk+-1.2.9.ebuild
new file mode 100644
index 000000000000..e1ddc4a24ec5
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.9.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtk"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}"
+HOMEPAGE="http://www.gtk.org"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.9
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 \
+ --infodir=/usr/X11R6/share/info --mandir=/usr/X11R6/share/man --sysconfdir=/etc/X11 \
+ --with-xinput=xfree --with-x
+ try make
+}
+
+src_install() {
+
+ try make install prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11 \
+ infodir=${D}/usr/X11R6/share/info mandir=${D}/usr/X11R6/share/man
+
+ preplib /usr/X11R6
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ cd html
+ docinto html
+ dodoc *.html *.gif
+
+ #install nice, clean-looking default gtk+ style
+ insinto /etc/X11/gtk
+ doins ${FILESDIR}/gtkrc
+}
+
+
+
+
diff --git a/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild b/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild
new file mode 100644
index 000000000000..7ceadd46a158
--- /dev/null
+++ b/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libPropList"
+SRC_URI="ftp://ftp.windowmaker.org/pub/release/srcs/current/${A}"
+HOMEPAGE="http://www.windowmaker.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr install
+
+ dodoc AUTHORS COPYING* ChangeLog README TODO
+
+}
+
+
+
+
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r1.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r1.ebuild
new file mode 100644
index 000000000000..e3c06fdc0b44
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.1.30-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r1.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=openmotif-2.1.30-4_MLI.src.tar.gz
+S=${WORKDIR}/motif
+DESCRIPTION="Open Motif (Metrolink Bug Fix Release)"
+SRC_URI="ftp://ftp.metrolink.com/pub/openmotif/2.1.30-4/"${A}
+HOMEPAGE="http://www.metrolink.com/openmotif/"
+
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.0.1"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/site.def ${S}/config/cf/
+}
+
+src_compile() {
+
+ mkdir -p imports/x11
+ cd imports/x11
+ ln -s /usr/X11R6/bin bin
+ ln -s /usr/X11R6/include include
+ ln -s /usr/X11R6/lib lib
+ cd ${S}
+ try make World
+}
+
+src_install() {
+
+ try make DESTDIR=${D} VARDIR=${D}/var/X11/ install
+
+}
+
+
+
+
+
+
+
diff --git a/x11-libs/qt-x11/files/digest-qt-x11-2.3.0 b/x11-libs/qt-x11/files/digest-qt-x11-2.3.0
new file mode 100644
index 000000000000..c01e7bb58beb
--- /dev/null
+++ b/x11-libs/qt-x11/files/digest-qt-x11-2.3.0
@@ -0,0 +1 @@
+MD5 f4993d952b9380a5009735aa1b7b9c03 qt-x11-2.3.0.tar.gz
diff --git a/x11-libs/qt-x11/qt-x11-2.2.4-r1.ebuild b/x11-libs/qt-x11/qt-x11-2.2.4-r1.ebuild
new file mode 100644
index 000000000000..470dc023c463
--- /dev/null
+++ b/x11-libs/qt-x11/qt-x11-2.2.4-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-2.2.4-r1.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/qt-${PV}
+DESCRIPTION="QT 2.2"
+SRC_PATH="kde/stable/2.0/distribution/tar/generic/src/${A}"
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/${A}"
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=media-libs/libpng-1.0.9
+ >=media-libs/libmng-1.0.0
+ >=media-libs/jpeg-6b
+ opengl? ( >=media-libs/mesa-3.4 )
+ nas? ( >=media-sound/nas-1.4.1 )
+ >=x11-base/xfree-4.0.2"
+
+export QTDIR=${S}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+}
+
+src_compile() {
+
+ export LDFLAGS="-ldl"
+ local myconf
+
+ if [ -z "`use opengl`" ]
+ then
+ myconf="-no-opengl"
+ fi
+
+ if [ "`use nas`" ]
+ then
+ myconf="${myconf} -system-nas-sound"
+ else
+ myconf="${myconf} -no-nas-sound"
+ fi
+
+ if [ "`use gif`" ]
+ then
+ myconf="${myconf} -gif"
+ fi
+
+ if [ "$DEBUG" ]
+ then
+ myconf="${myconf} -debug"
+ else
+ myconf="${myconf} -release"
+ fi
+
+ ./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
+ -system-libmng -system-libpng -gif -platform linux-g++ -ldl -lpthread
+
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/tools
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/src/moc
+ cp Makefile Makefile.orig
+ sed -e "s/-pipe -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}
+ try make symlinks src-moc src-mt sub-src sub-tools
+}
+
+src_install() {
+
+ QTBASE=/usr/X11R6/lib
+ cd ${S}
+ dodir $QTBASE/${P}
+ into $QTBASE/${P}
+ dobin bin/*
+ dolib.so lib/libqt.so.${PV}
+ dolib.so lib/libqt-mt.so.${PV}
+ dolib.so lib/libqutil.so.1.0.0
+ preplib $QTBASE/${P}
+ dosym libqt.so.${PV} $QTBASE/${P}/lib/libqt.so
+ dosym libqt-mt.so.${PV} $QTBASE/${P}/lib/libqt-mt.so
+ dosym libqutil.so.1.0.0 $QTBASE/${P}/lib/libqutil.so
+ cd ${D}${QTBASE}
+ ln -sf qt-x11-${PV} qt
+ cd ${S}
+ dodir ${QTBASE}/${P}/include
+ cp include/* ${D}${QTBASE}/${P}/include/
+ doman doc/man/man3/*
+
+ dodoc ANNOUNCE FAQ LICENSE.QPL MANIFEST PLATFORMS
+ dodoc PORTING README*
+ cp -af ${S}/doc/html ${D}/usr/doc/${P}
+ insinto /etc/env.d
+ doins ${FILESDIR}/90qt
+
+}
+
+
+
+